Bug: Can't update via checkbox if column names are used in query

An example of what does work:

  • select * from oltp.dbo.Settings

I can then check and uncheck the boolean fields and Auto-commit automatically updates the necessary fields in the database.

An example of what does not work:

  • select COL1, COL2, COL3 from oltp.dbo.Settings

You would expect the same behavior, that for a standard select statement any bit based columns can have their values updated. This is not the case.

Sorry if this is a pre-existing bug. I couldn't find anything (granted I didn't look too long. I am at work afterall :) )


This is for a sql server database using windows auth with the jTds driver, if it matters.



Saw this behavior quite long ago, was sure it's by design. I'm forwarding your question to developers, since this causes troubles.



Thank you. I can understand this behavior being disabled for joins, nested select statements and other nasty stuff like that, but for a single select statement it would be nice to be able to specify which columns are displayed.


Hi, Daniel!

Please, make sure your column names include the primary key - otherwise editing values in rows doesn't make sense.


Thanks for the reply. I just double checked, and it does.

  • select PK1, PK2, PK3, COL1 from oltp.dbo.settings

Still not working though. I believe Alexander may be correct in that this is by design.


Thanks for reporting. We are going to improve the detection algorith.
Feel free to create YouTrack ticket to get notified when it is fixed.

UPDATE: I've mentioned this thread in http://youtrack.jetbrains.com/issue/DBE-672


Please sign in to leave a comment.