I hit a similar error at first, but was able to fix the problem with the following steps:

* Open the 'new datasource" panel
* Expand drivers on the left hand menu
* Click PostgreSQL
* In the "Driver files" section at the bottom, there was a link to download the driver files

Clicking this link automatically downloaded the driver and I was then able to connect successfully.  Since I was on Windows, your mileage may vary.  But hopefully this fixes the problem for you as well!


Hey Geoff, thanks very much!  Yes, this appears to have fixed it for me as well.


What if there isn't a link to download driver files, but it still says they are missing?


DataGrip was working fine - then it just started getting this error. I updated with the latest version. That didn't fix it. I tried the suggestion above - but I don't see a link to download drivers.

How do I resolve this issue??


You can click on the Postgres Driver files and select which version to use/download in the Data Sources and Drivers setting.

Depending on proxy settings, you won't be able to download them (or only partially). You should have these files under the jdbc driver folders (check the size as well):

If they are not there copy from a working datagrip installation.


Hi all. i have the similar problem, on win10 i select version and IntelliJ idea download it but i steel have error

Exception in thread "main" java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.intellij.rt.execution.CommandLineWrapper.main(CommandLineWrapper.java:67)
Caused by: java.lang.ClassNotFoundException: org.postgresql.Driver
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:264)
at com.intellij.database.remote.RemoteJdbcServer.main(RemoteJdbcServer.java:14)
... 5 more.


Intellij idea support team solved my trouble on windows 10.


For fix add to custom vm Options do:
Help=>custom vm Options=> add


Please sign in to leave a comment.