Compile Server TCP Port Setting is Missing

Hello.

I am using the IntelliJ 14 Community, just installed Scala Plugin 1.1.1.
I don't see the TCP Port setting on the plugin configuration page.
Is there a way to change the default port?


Scala Plugin v0.41.2:

Run compile server (in extarnal build mode)


TCP Port                      3200
JVM SDK:                      1.7 (java version "1.7.0_60")
JVM maximum heap size, MB     1024
JVM paramaters:               ...


Scala Plugin v1.1.1:

Run compile server (in extarnal build mode)


JVM SDK:                      1.7 (java version "1.7.0_60")
JVM maximum heap size, MB     1024
JVM paramaters:               ...


Thank you

2 comments
Comment actions Permalink

Hi, Michael,

We decided that it is better to find a free port automatically without asking the user. You can see the port number in the tooltip at compile server icon (see screenshot). If you want to change it you need to add or change the following line in <config_dir>/options/scala.xml:
<option name="COMPILE_SERVER_PORT" value="52621" />

Why do you need to change it? Do you have problems with automatically found one?

0
Comment actions Permalink

Hello, Nikolay.

Thank you for the quick response.

I was running 2 IntelliJs (13 and 14), both running Scala projects. So I got "Address already in use" error in the Event Log.

The project did run though, so maybe IntelliJ 14 can report a warning instead of an error?

Thank you.

0

Please sign in to leave a comment.