Exception in thread main

Hi,

I'm trying to run Groovy unit tests, but when I do that, I get an error: "Exceptin in thread main". This actually happens for all groovy stuff, be it unit tests or normal groovy applications. For example, running this:


Gives this output:

Information:Compilation completed with 1 error and 0 warnings
Information:1 error
Information:0 warnings
Error:Exception in thread "main"

Help!

0
16 comments

Hello, Erik.

I'm afraid I cannot reproduce this behavior. This example works fine for me on IDEA 8823 (last EAP). Could you describe some environment, such as your Groovy/Java version etc. to help me?

0

Sorry, I think this is caused by a defragmentation 'feature': I was defragmentating my HD, and I cancelled that while it was in progress. I think my IntelliJ installation got damaged. I'll reinstall, and try again!

0

Hi,

I have the same problem. I tried deleting the caches and the generated java files. Sometimes it works, e.g. I don't get the error but not for long.
Also deleted my .IntelliJIdea80 folder completely to no avail.

I am using Diana builds with jdk1.6.0_10 on windows xp sp2 since build #8840 and had the problem on each build. Never had the problem on Selena.

I am using groovy-all-1.5.6.jar and JDK 1.5.0_12 or JDK 1.6.0_10 (depending on the project) as the compiler.

Sébastien

Edited by: Sébastien on Nov 5, 2008 4:51 PM

0

I am seeing this exact same error. My project JDK is 1.4.2_17 due to deployment constraints. Totally freshly installed release 8.0 and Grails 1.0.3.

Is there any way to force IDEA to dump context on that error?

0

I can reproduce the same error with new generated, blank grails project with Diana build 9008 running on JDK 1.6.0_10.
Project: JDK is 1.5.0_16, Grail 1.0.3

Thanks for your help
Thomas

0

Thomas Aichernig wrote:

I can reproduce the same error with new generated, blank grails project with Diana build 9008 running on JDK 1.6.0_10.
Project: JDK is 1.5.0_16, Grail 1.0.3

Thanks for your help
Thomas


You can add the following tag to your log.xml in IDEA bin folder:

]]>

Restart IDEA, run the compilation, go to your IDEA system/log directory
(most probably ~/IntelliJIDEA8.0/system/log) and post the log file
contents here. It should help us in reproducing the problem.

0

Here is mine...



Attachment(s):
idea.log
0

Sébastien wrote:

Here is mine...

Thank you very much! Now we're ready to the next stage of remote
debugging. Could you replace the groovy_rt.jar in ]]>/Groovy/ with the attached file and send us more logs after that?



Attachment(s):
groovy_rt.jar
0

Having the same problem. Here are my logs as well.

Edited by: Mike Cantrell on Nov 11, 2008 9:54 PM

Uploaded log from a blank, new project.



Attachment(s):
log.zip
0

Mike Cantrell wrote:

Having the same problem. Here are my logs as well.

Thank you. You could replace groovy_rt.jar too, and get new logs, after
this change.

0

Hi,

Replaced the jar and everything seems to work now...
Just in case, attached you'll find my log file.

Sébastien

Edited by: Sébastien on Nov 11, 2008 2:35 PM



Attachment(s):
idea.log
0

Sébastien wrote:

Here is mine...

Thank you very much! Now we're ready to the next stage of remote
debugging. Could you replace the groovy_rt.jar in <IDEA plugins
directory>/Groovy/ with the attached file and send us more logs after that?


Peter - I had the same problem as the others. I added the log.xml tag and I also replaced the groovy_rt.jar with your attached copy. After replacing the groovy_rt.jar I no longer have the original issue. I'm not sure if it will be any use since it stopped happening, but I'm attaching my idea.log from after I updated the groovy_rt.jar. Let me know if you need me to try anything else.

Gary



Attachment(s):
log.zip
0

G.Stewart wrote:
>>

>> Sébastien wrote:
>>> Here is mine...
>> Thank you very much! Now we're ready to the next stage of remote
>> debugging. Could you replace the groovy_rt.jar in > directory>/Groovy/ with the attached file and send us more logs after that? >>]]>


Peter - I had the same problem as the others. I added the log.xml tag and I also replaced the groovy_rt.jar with your attached copy. After replacing the groovy_rt.jar I no longer have the original issue. I'm not sure if it will be any use since it stopped happening, but I'm attaching my idea.log from after I updated the groovy_rt.jar. Let me know if you need me to try anything else.

Gary


This is really very strange because all the changes I made was just to
add one catch section that would log every Throwable stack trace. It's
some kind of magic, but it works, so let it be. BTW you've promised some
logs but apparently forgot to attach them?

0

Peter,

I am using IDEA 8 Build #9013. I had the same problem as the others and replaced my groovy_rt.jar file with your attached copy. My build now works. I did notice that the Exception was thrown in the "copying resources" phase of the build after it appeared that it had successfully compiled all of my java and groovy files.

Attached is my log which contains some exceptions which I hope will shed light on the source of the problem.

Thank you,
Brenton



Attachment(s):
idea.log
0

Thank to everyone who participated. The fix will be included in the next
IDEA update (8.0.1, I suppose).

0

This is really very strange because all the changes I made was just to
add one catch section that would log every Throwable stack trace. It's
some kind of magic, but it works, so let it be. BTW you've promised some
logs but apparently forgot to attach them?


I can see a log.zip attached to my post and I was able to dl it myself. Can you not access it? I'll attach it again to this one.



Attachment(s):
log.zip
0

Please sign in to leave a comment.