Constantly asked if I want to upgrade application

Hi, since upgrading to IDEA 7.0.3 with JetGroovy (several versions, I'm currently running the latest 1.5 available from the plugin manager) I constantly get a dialog saying "Application has Grails version 1.0.2, but current Grails version is undefined. Upgrade application?". Everyone on my team using IDEA is getting the same message. We're all on Ubuntu Linux, Java 6, Grails 1.0.2. Curiously I don't get it at home on my Mac. The Groovy & Grails installation directories are set up correctly & show up in the global libraries. GRAILS_HOME in the OS is set correctly and GRAILS_HOME/bin is on the PATH so I'm not sure what could be causing this. Any help appreciated.

5 comments
Comment actions Permalink

What does your application.properties look like?

0
Comment actions Permalink

Here's the contents of my application.properties. However, the message implies that the plugin is happy with the grails version of the app but can't identify what grails version is installed on the machine.

#Do not edit app.grails.* properties, they may change automatically. DO NOT put application configuration in here, it is not the right place!
#Mon Apr 28 11:19:37 BST 2008
app.version=0.1
build.number=null
build.id=null
app.servlet.version=2.4
app.grails.version=1.0.2
svn.revision=null
build.job.name=null
app.name=entertainment

0
Comment actions Permalink

Rob,

What version of Grails are you using now? It seems that JetGroovy cannot determine your current grails version. It might be placed in META-INF/MANIFEST.MF file at your GRAILS_HOME/dist/grails-core-[version].jar. Please, look at Implementation-Version property.

0
Comment actions Permalink

One more question. How was your GRAILS global library created? Did you set up Grails installation path in appropriate configuration dialog or created GRAILS library directly? In second case plugin was not able to determine current grails version. To fix it try to change your Grails installation path using configuration dialog.

0
Comment actions Permalink

Aha!

We are using a patched version of the grails-core jar and since we were using the Gant jar command to create it the proper manifest.mf wasn't there. Fantastic. Thanks for pointing me in the right direction.

0

Please sign in to leave a comment.