Recent plugin version has trouble with my projects

Hi there,

is it possible that the Scala plugin's code analysis has been seriously degraded in one of the frequent recent updates? I am having at least two projects now which bring it completely to halt. There seems to be no pattern, it happens in all sorts of files. The 'eye' in the top right corner just doesn't advance, and the colorisation stays at the 'shallow' level. Sometimes more colorisation is added while I click into random spots of the sources, but it has not fully finished, e.g. code completion is broken, no suggestions are found for importing symbols, a lot of white space is red underlined. Editing these files is almost as comfortable as in plain ASCII editor, almost nothing works.

I already ran cache invalidation, and I also tried to set my project's Scala version back from 2.11.0 to 2.10.4; this doesn't seem to affect the situation.

I have attached two screen shots, you can see from the colours that after a random line, the analysis just stops.

( Perhaps related: There seems to be a new bug with name shadowing. E.g. if I have symbol 'Foo' in default scope (e.g. package), and I import another 'Foo' from somewhere else, the plugin renders all occurrences of 'Foo' in red, instead of using the shadowing symbol. )

I am using IntelliJ IDEA CE 13.1.2 Build 135.690 with Scala plugin 0.35.683.

Best, .h.h.



Attachment(s):
Screenshot from 2014-04-25 23:47:08.png
Screenshot from 2014-04-25 23:45:15.png
4 comments

Then suddenly analysis comes back, until it hangs at another point. I have attached another screenshot - the plugin suggested the import of `DoubleVecElem`, but then puts a red mark at the end of the import, and doesn't see that I added the `Vec` import, showing `Vec` in red and failing with the type inference...



Attachment(s):
Screenshot from 2014-04-26 00:00:51.png
0

To reproduce:

    $ git clone git@github.com:Sciss/SoundProcesses.git -b extensible-attrs
    $ cd SoundProcesses
    $ git checkout -b test dc3a391d5b35704828967f214dce61d22992784d
    $ sbt gen-idea

Then in IntelliJ IDEA, open the project and file proc/src/test/scala/de/sciss/synth/proc/AttributesSpec.scala -- analysis hangs

0

Thank you. I fixed stackoverflow in new highligthing for patterns: https://github.com/JetBrains/intellij-scala/commit/1f3c605ce4088a22fb7eadcc6718bcfa74a0a595
The fix will be available in next nightly build or next week in next regular update.

Thank you for the report.

Best regards,
Alexander Podkhalyuzin.

0

Thanks Alexander; I'm again on that project and it's stalling; so I tried to install Scala nightly plugin now, and the problem has disappeared so far. Great!

0

Please sign in to leave a comment.