JetGroovy 1.5.14891 + IDEA 7.0.3 => 100% CPU Use When Viewing Groovy Source

Earlier today I upgraded JetGroovy to the latest (1.5.14891) with no problems.

A while later I upgraded to the just-released 7.0.3 release of IDEA. Upon restarting after that installation, I find that IDEA consumes 100% CPU when a Groovy file is being displayed. Switching to a different file causes the CPU use to subside but switching back to a Groovy file cause the CPU to saturate again. This is not just for the duration of the code analysis, it persists indefinitely.

This does not occur when viewing a GSP file, only a Groovy source file.

Arch: x86
OS: Linux (KDE)
JVM: Sun Java 1.6.0_04


Randall Schulz

21 comments
Comment actions Permalink

Could you please upload a CPU snapshot to ftp://ftp.intellij.net/.uploads ?

0
Comment actions Permalink

Gladly, but I don't know the procedure for producing them. Are there instructions somewhere?

0
Comment actions Permalink

If you use EAP version of IDEA there is are two icons in toolbar for taking snapshots, one for CPU and the other for memory snapshot. Please use the former. If you use the release, then you would need to trigger the action from YourKit itself.

0
Comment actions Permalink

I've never seen such buttons, whether I'm using EAP or final releases.

However, I did some searching in the Forum archives and found that by putting this line:

in my .../bin/idea.vmoptions file and restarting, I now see memory and CPU snapshot buttons in my toolbar.

I captured several seconds of the 100% CPU usage with a Groovy file open and uploaded the resulting Zip file it to ftp://ftp.intellij.net/.uploads/7757_rschulz_13.03.2008_12.44.35.zip

By the way, I neglected to mention that when I was viewing a virtual desktop other than the one in which IDEA was displayed, the CPU usage dropped back to zero.

Randall Schulz

0
Comment actions Permalink

This is a problem with out groovydoc support. Could you please post an offending doc comment for us to reproduce?

0
Comment actions Permalink

I'm running into a similar problem (CPU chugging along while looking at groovy source). If I view this source, the CPU will spike continuously while I'm viewing the file.

Here's the example:






/**

  • Created by IntelliJ IDEA.

  • @author kriega

  • @version $$Revision$$

  • Date: Mar 13, 2008

  • Time: 6:26:02 PM

*/
class LogLoaderTest extends GroovyTestCase {

public void testLogConfig(){
def props = '''handlers = 'java.util.logging.ConsoleHandler, java.util.logging.FileHandler'
java{
util{
logging {
ConsoleHandler{
level = 'INFO'
formatter = 'java.util.logging.SimpleFormatter'
}

FileHandler {
level = 'ALL'
pattern= "${LESTER_DIR}/logs/$.log"
}

}
}
}


// set the package log levels
com{
gs {
cipher = 'INFO'
gsat = 'FINE'
}
}
'''
ConfigSlurper slurper = new ConfigSlurper();
slurper.setBinding (
["LESTER_DIR":".",
"APP":"lester"
]
)
Properties readProps = slurper.parse("./config/logging.groovy").toProperties();

assertEquals("INFO",readProps.get("com.gs.cipher"));
assertEquals("./logs/lester.log",readProps.get("java.util.logging.FileHandler.pattern"));

}

}

0
Comment actions Permalink

I don't think that's it. It's happening for me in Groovy files with no documentation comments.

Randall Schulz

0
Comment actions Permalink

Just wanted to say I have the same issue over here. I can't attach a CPU snapshot at the moment, but if you want one, please let me know.

Btw, IntelliJ is also eating up (650MB) all the memory I gave it.

0
Comment actions Permalink

I'm also experiencing a CPU utilization spike whenever I'm viewing groovy source with 1.5.14891 and 7.0.3.

0
Comment actions Permalink

OK, the issue will be fixed in the next JetGroovy build.

0
Comment actions Permalink

Thank you!

Can you give us an ETA on that?


Randall Schulz

0
Comment actions Permalink

Minus 5 minutes. I mean it's already available:)

0
Comment actions Permalink

Thanks again.

I checked http://plugins.intellij.net/plugin/?id=1524 before asking (but not the IDEA plug-in manager itself), but that page was (and still is) showing 14891.

RRS

P.S. I can confirm the problem is fixed here.

Message was edited by:
Randall Schulz

0
Comment actions Permalink

Eugene, I don't know how you do it, but your software releases (and bugfixes) are the fastest ever! Great work, thanks!!

0
Comment actions Permalink

Am I the only one where this is still an issue w/ the latest JetGroovy and the released 7.0.3? IDEA still locks up for me when I view a .grooovy file. I will post a couple cpu snapshots.

Thanks.
-Brandon

0
Comment actions Permalink

I uploaded a snapshot to ftp.intellij.net, filename: 7757_blonac_18.03.2008_23.49.18.zip.

This is happening whenever IDEA gains focus with a .groovy flie in display after using another application. It looks like there is a lot of disk writes as well.

JetGroovy 1.5.15022 + IDEA 7.0.3 final

OS X 10.5.2

-Brandon

0
Comment actions Permalink

Brandon,
your snap[shot again shows perforce activities, not jetgroovy. What is the perforce status of your files?

0
Comment actions Permalink

The file is open for edit. It seems to happen when I come back to IDEA from another app. It does not happen though in a java only project.

Thanks for looking again.
-Brandon

0
Comment actions Permalink

Actually this looks to happening after a maven build. I am using the maven plugin to run the grails app. it must be all file copying of files that is setting the perforce plugin into a tizzy.
-brandon

0
Comment actions Permalink

Hello Brandon,

Actually this looks to happening after a maven build. I am using the
maven plugin to run the grails app. it must be all file copying of
files that is setting the perforce plugin into a tizzy.


If you have a directory with generated code which is not stored in Perforce,
you should set VCS to None for it in Settings | Version Control | Directory
Version Control Settings.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thank you! That was my issue.
-Brandon

0

Please sign in to leave a comment.