Prevent line wrapping and identation when using a lambda arguments

There is a recent (IDEA 13.1?) change in Scala style formatting which drives me nuts. In short, when I write this:

  foo { implicit tx =>
    1 + 1
  }



it soon gets reformatted as:

  foo {
    implicit tx =>
      1 + 1
  }


How can I teach IDEA to respect to upper form?

Another example. This is what I want:

        bodies.flatMap { body =>
          foo(body, head)
        }


This is what I get

        bodies.flatMap {
          body =>
            foo(body, head)
        }




Thanks!

1 comment

Hi!

Settings / Code Style / Scala / Wrapping and Braces / Anonymous method definition / Parameters on new line :)

I wonder whether we should turn it off be default (SCL-6927)...

0

Please sign in to leave a comment.