Before you release Jetgroovy 1.0...

PLEASE fix the Groovy class recognition when I start the IDE. What I'm talking about is the situation where I create classes (typically domain classes) and when I restart Idea all my references are red and I have no auto-completion and I can't find them with CTRL-n.

I have been using the work around of reformatting the code in all my classes and then switching it back but that is causing hell on my team for CVS check-ins.

If I'm doing something wrong please tell me...

6 comments
Comment actions Permalink

Are you sure you use the latest plugin? This situation could arise earlier, but we completely rewrote relevant functionality.

0
Comment actions Permalink

Yes I just downloaded the latest plugin....is it possible that IDEA is picking up an older plugin from a previous version? I've uninstalled each version of idea except 7.01...

I'll try manually removing the plugin and re-downloading it.

0
Comment actions Permalink

I turned of Idea, deleted the "groovy" directory from the plugins directory in
C:\Documents and Settings\username\.IntelliJIdea70\config\

Restarted Idea, re-downloaded Jetgroovy, and still getting unrecognized classes....any suggestions? This is happening both at work and at home.

0
Comment actions Permalink

Do you have groovy facet attached?

0
Comment actions Permalink

Steve, please, make sure that your classes (domain etc.) are placed in project source directories. In project view directories like 'domain', 'taglib', 'serveices' etc. must be marked blue.

0
Comment actions Permalink

That seemed to do it! Thanks a bunch.

0

Please sign in to leave a comment.