Error opening settings dialog

I"m running IDEA IU-132.425 with scala plugin version 0.21.50.

After updating to the latest version of the EAP, I'm unable to open the project settings dialog.  I get the following error:

2013-09-30 10:14:03,234 [  11277]  ERROR - ellij.project.impl.ProjectImpl - org.jetbrains.plugins.scala.compiler.CompileServerManager@4b29f72c
java.lang.NoSuchFieldError: USE_COMPILE_SERVER
 at org.jetbrains.plugins.scala.compiler.CompileServerManager.applicable(CompileServerManager.scala:80)
 at org.jetbrains.plugins.scala.compiler.CompileServerManager.configureWidget(CompileServerManager.scala:55)
 at org.jetbrains.plugins.scala.compiler.CompileServerManager.projectOpened(CompileServerManager.scala:41)
 at com.intellij.openapi.project.impl.ProjectImpl.c(ProjectImpl.java:420)
 at com.intellij.openapi.project.impl.ProjectImpl.access$200(ProjectImpl.java:76)
 at com.intellij.openapi.project.impl.ProjectImpl$MyProjectManagerListener.projectOpened(ProjectImpl.java:457)
 at com.intellij.openapi.project.impl.ProjectManagerImpl$2.projectOpened(ProjectManagerImpl.java:155)
 at com.intellij.openapi.project.impl.ProjectManagerImpl.e(ProjectManagerImpl.java:1050)
 at com.intellij.openapi.project.impl.ProjectManagerImpl.openProject(ProjectManagerImpl.java:415)
 at com.intellij.openapi.project.impl.ProjectManagerImpl.loadAndOpenProject(ProjectManagerImpl.java:506)
 at com.intellij.ide.impl.ProjectUtil.openProject(ProjectUtil.java:179)
 at com.intellij.ide.RecentProjectsManager.doOpenProject(RecentProjectsManager.java:46)
 at com.intellij.ide.RecentProjectsManagerBase$MyAppLifecycleListener.appStarting(RecentProjectsManagerBase.java:350)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:601)
 at com.intellij.util.messages.impl.MessageBusConnectionImpl.deliverMessage(MessageBusConnectionImpl.java:114)
 at com.intellij.util.messages.impl.MessageBusImpl.doPumpMessages(MessageBusImpl.java:228)
 at com.intellij.util.messages.impl.MessageBusImpl.pumpMessages(MessageBusImpl.java:219)
 at com.intellij.util.messages.impl.MessageBusImpl.sendMessage(MessageBusImpl.java:209)
 at com.intellij.util.messages.impl.MessageBusImpl.access$000(MessageBusImpl.java:43)
 at com.intellij.util.messages.impl.MessageBusImpl$1.invoke(MessageBusImpl.java:131)
 at $Proxy41.appStarting(Unknown Source)
 at com.intellij.idea.IdeaApplication.c(IdeaApplication.java:394)
 at com.intellij.idea.IdeaApplication.access$600(IdeaApplication.java:64)
 at com.intellij.idea.IdeaApplication$IdeStarter$2.run(IdeaApplication.java:361)
 at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.run(LaterInvocator.java:347)
 at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
 at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:721)
 at java.awt.EventQueue.access$200(EventQueue.java:103)
 at java.awt.EventQueue$3.run(EventQueue.java:682)
 at java.awt.EventQueue$3.run(EventQueue.java:680)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
 at java.awt.EventQueue.dispatchEvent(EventQueue.java:691)
 at com.intellij.ide.IdeEventQueue.e(IdeEventQueue.java:696)
 at com.intellij.ide.IdeEventQueue._dispatchEvent(IdeEventQueue.java:524)
 at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:335)
 at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
 at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
 at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)

Is there anything I can do locally to fix it (edit a config file, etc)?

Thanks,

-Austen

3 comments

i guess the plugin is simply not compatible andwe have to wait for an update

0

I'll upload right build in few hours. Sorry for delay.

Best regards,
Alexander Podkhalyuzin.

0

Works now. Thanks for the fix. :)

-Austen

0

Please sign in to leave a comment.