Autocomplete support for editing a Scala script

Hi,

How can I edit with autocomplete support a Scala script in latest version of IDEA, 12.1.4.
Out of the box, I have syntax highlighting :-) , but when I enter ".", no methods are shown.

In the module settings of the project:

  • I have set the content root to the folders that contain Scala scripts,
  • Set language level to 7.0
  • Have added a Scala facet, to 2.10, and set the Scala compiler path.


But all this seems not to be enough.  :-(

Working in Linux.

I'm quite new to IDEA and Scala, so sorry if this is a stupid question.

David
8 comments

Can you attach here your configured project? Then I'll tell you what's wrong.

Best regards,
Aleksandr Podkhaliuzin.

0

Thanks Aleksandr,

It is a project imported from Eclipse, that used to contain only resources, i.e. not executable code.
I'm currently evaluating IDEA.

I've attached *.eml, *.iml and .project from Eclipse.

David



Attachment(s):
.project.zip
configuracion-linux.iml.zip
configuracion-linux.eml.zip
0

Do you have ".idea" folder in your project? It contains almost all project settings, except module settings from iml file, which you just attached.

Best regards,
Aleksandr Podkhaliuzin.

0

Here it is.

I would like to mention is that my Scala script only uses standard Java and Scala API's, no external libs.



Attachment(s):
.idea.zip
0

Is there any special setup needed for cases like this?.

0

I don't see any Scala library in your libraries folder. You should configure library, which contain scala-library.jar and scala-reflect.jar, then attach it to the module, where you are trying to use scala script. Setting up compiler library in Scala facet is not enough to get it working.

Best regards,
Aleksandr Podkhaliuzin.

0

Thanks for your unvaluable help.
It now works smoothly.

0

Thanks for your unvaluable help.
It now works smoothly.

0

Please sign in to leave a comment.