Importing ScalaZ libraries causes IntelliJ to abuse processor

Hi, after I import ScalaZ libraries into IntelliJ, the IntelliJ starts using a huge amount of processing - specifically in proportion to those files that use ScalaZ types. Is there any way 'round this?
~gilbert

4 comments

In the redesign of Scalaz 7, we organized things so you could selectively import
the implicits you needed, rather than `import Scalaz._`.

Potentially this can help out with compiler and IDE performance.

Otherwise, it would be best to create a small sample project that demonstrates the problem, and report a bug.

0

In which version of Scala plugin do you have problems?
Please create CPU snapshot (http://devnet.jetbrains.com/docs/DOC-192) with your freezings, then I'll be able to suggest you possible workarounds and probably will find a way to fix it.

Best regards,
Alexander Podkhalyuzin.

0

Hi Guys, I have have just alleviated the issue by narrowing the imports of ScalaZ as Jason suggested. The issue was with importing the entire Scalaz._ object (import _root_.scalaz.Scalaz._)
Alexander, I am using v        0.7.264 of the scala plugin - with ScalaZ 7. FTP'd my cpu usage to: IU-129.451_Gilbert_20.05.2013_22.21.18.zip

Brief machine specs:
Intel i7-2720QM 2.2GHz
14GB RAM
256GB SSD
Win7 64

0

Please try to increase your IDEA heap memoty size. You are using default 512M setting, try to change it to 1024M (http://www.jetbrains.com/idea/webhelp/increasing-memory-heap.html). This is probably will help you with GC.

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.