Scala Code Style setting for import wildcard gone?

In the new IntelliJ 12 plug-in, the Scala preferences for imports seem to be gone; at least I can't find them?

I still have my Code Style Settings from IntelliJ 11, in which there should be a large number (50) for members to import before falling back to wildcard import. But that isn't displayed nor respected, going back to the default (?) of 4 which is inacceptable for me. E.g. from

    import actors.{TIMEOUT, DaemonActor, Actor, Channel}

if I let IDEA add another import, such as OutputChannel, the above statement is rewritten as

    import actors._

which shadows different names in my namespace.

How can I restore the setting so that imports do not fall back to wildcards?

Thanks, .h.h.

---
Original message URL: http://devnet.jetbrains.net/message/5473544#5473544

0
1 comment

nevermind, that setting was in the main Scala settings tab, not in Code Style


0

Please sign in to leave a comment.