fsc, leda + scala 2.10m4,5,6

hi,

all i get is an internal compiler error 1
is there something special i need to do to make the fsc work?

7 comments
Comment actions Permalink

The problem with such a problem is that we can't easily reproduce the problem :) I'm using Leda with Scala m6 and everything seems to work fine...

Can you please provide a sample project configuration?

Additionaly, you may try to configure FSC in a new blank project to see whether it works there.

0
Comment actions Permalink

providing the actual error message would be a good start, imho.

0
Comment actions Permalink

i messed around and fixed my problem my putting my scala library on the top of my module dependencies.

0
Comment actions Permalink

now i am getting the error again without changing anything. i use 2 modules, maybe that's a reason?
stopping the fsc seems to fix the problem for a few recompilations until it breaks for some unknown reason.

is there anything special i need to do in order to set up a module or the global library i use when using an fsc?

0
Comment actions Permalink

I've also been having trouble with fsc and IntelliJ 11.1.3 with Scala plugin 0.5.948.

Mac OSX Snow Leopard.  JDK 1.6.0_33

It started showing up for no apparent reason when I was using Scala 2.9.1.  I upgraded to 2.9.2 in my maven project and downloaded Scala 2.9.2 but the problem still persisted.

The issue occurs when Using the FSC in Compiler -> Scala Compiler -> Project FSC with the "Run internal server" radio button checked.  No stack-traces inside idea.log.

My work-around is:
1. start up the FSC

2. open a Terminal and determine the FSC process:
$ ps aux | grep CompilerServer

3. kill all FSC processes and start it up manually.  This can be determined from the output of the step 2.  On my system I ran:
$ /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin/java -Xmx1024m -Xms768m -Xss1m -server -cp /Users/skiyooka/.m2/repository/org/scala-lang/scala-compiler/2.9.2/scala-compiler-2.9.2.jar:/Users/someuser/.m2/repository/org/scala-lang/scala-library/2.9.2/scala-library-2.9.2.jar scala.tools.nsc.CompileServer -v

You will see output similar to:

Starting CompileServer on port 62958
Redirect dir is /var/folders/81/81PvOln2EymlcU+UCwtEE++++TI/-Tmp-/scala-devel/someuser/output-redirects


4. In the Compiler -> Scala Compiler -> Project FSC choose the "Connect to external server" instead of "Run internal server" radio button.

For the Host/Port use localhost and the port seen in the output of step 3 e.g. 62958.

0
Comment actions Permalink

it seems the FSC doesn't like the "optimize code" option for some reason. switching it off fixed the problem

0
Comment actions Permalink

Yes, the "optimize" option is a known potential problem (e.g. the Scala plugin project itself cannot be compiled with that option regardless of the FSC usage).

It seems that we should add a respective notice to the "optimize" option in the configuration dialog.

0

Please sign in to leave a comment.