*.scala file is not recognized as Scala file

I am having trouble setting up a Scala project and any help would be appreciated.

I used to be able to simply auto-generate project files using sbt-idea around a year ago,
but when I am trying it again with IntelliJ 11.1.2 CE (117.418) and Scala Plugin 0.5.913,
*.scala file is no longer recognized as Scala file. Syntax highlighting doesn't work and compiler doesn't recognize them either.

To reproduce the issue with simpler use case, I've also tried creating projects manually using manually downloaded Scala 2.9.2 and 2.10.0-M5.
I see Scala facets under modules, and I can right-click to see New > Scala Class context menu, so the setup looks ok.
When I create Foo.scala under some package, the project tree shows the file in plain text icon, and the editor renders it as plain text.

When I expand scala-library.jar, however, the classes and traits are displayed in icon, and the Scala signatures are rendered
with syntax highlight.

I've also tried Nika 117.747, but the result was the same. What am I doing wrong?

2 comments
Comment actions Permalink

Open Settings -> File Types and remove "scala" extension from Plain Text file type.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Thank you!

Under File Types, both *.scala and *.sbt were categorized under Text files.
I removed and recreated them under Scala files and things are looking normal.

0

Please sign in to leave a comment.