CompileServer does nothing

I am using Scala 2.8.1 and Idea 10.5 with Scala plugin 0.4.1338.

I would like to use a Scala Compilation Server Run Configuration so
I can click on errors and have them navigate me directly to the line
of code.

I created a run configuration and ran it.  The Run window opens with
the command

/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home/bin/java
-Denv.classpath="%CLASSPATH%" -Denv.emacs="%EMACS%" -
Didea.launcher.port=7533 -Didea.launcher.bin.path=/Applications/Xena-
IU-107.481.app/bin -Dfile.encoding=MacRoman -classpath /Users/
ericpederson/.m2/repository/org/scala-lang/scala-compiler/2.8.1/scala-
compiler-2.8.1.jar:/Users/ericpederson/.m2/repository/org/scala-lang/
scala-library/2.8.1/scala-library-2.8.1.jar:/Applications/Xena-IU-107.481.app/lib/idea_rt.jar
com.intellij.rt.execution.application.AppMain scala.tools.nsc.CompileServer

But then nothing else happens.   I have tried saving changes and also running my app.  
Checking ps shows the process running.  

I also tried using Settings->Compiler->Scala Compiler->Use fsc but that
does nothing.   No process starts, no output is displayed.  

Any ideas?

2 comments
Comment actions Permalink

Fsc support will be available soon. I think this Run Configuration will be removed.
Also Scala Compilation Server Run Configuration is only for running compilation server from IDEA (in new fsc support it will be automatically). So it's ok what you described.
To see errors and to navigate to them you should compile code manually.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

You may check Real FSC support blog post.

0

Please sign in to leave a comment.