Can't get idea to work with 2.9.0 (when using FSC)

I know it has only just been released but I can't seem to get 2.9.0 to work with idea when using the FSC.

I start the FSC fine and then when I try to build I get this:

Scalac internal error: class java.lang.NoSuchMethodException [java.lang.Class.getMethod(Class.java:1605), org.jetbrains.plugins.scala.compiler.rt.FastScalacRunner.main(FastScalacRunner.java:60)]java.lang.Class.getMethod(Class.java:1605)
org.jetbrains.plugins.scala.compiler.rt.FastScalacRunner.main(FastScalacRunner.java:60)



Any ideas?

Thanks, Nick.
4 comments
Comment actions Permalink

Have you updated to the latest nightly build of the Scala plugin?

0
Comment actions Permalink

Ah no, I'm just using the latest released plugin.

Is there going to be a release soon?

Thanks, Nick,

0
Comment actions Permalink

Yes, I'll add to available plugins list one version today (compatible with the latest IDEA 10.5 RC). Next version will be added with 10.5 release.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Great news.

Thanks, Nick.

0

Please sign in to leave a comment.