IntelliJ incredibly slow while typing

I'm using IntelliJ IDEA 10.0.03 Community Edition with the Scala plugin 0.4.735. The longer I've been working on my project, the more frustrating this problem has become. It became extremely apparent after adding a JDBC Wrapper called Squeryl. Its nearly making IntelliJ unusable for me to work on. I found this discussion that suggested disabling language injection, but it appeared as if this problem was corrected? I would like to keep as many code-completion features enabled as possible, since when they work they do save me a considerable amount of time.

To be specific, whenever I'm typing - not matter the context (can be within a string, wherever) IntelliJ will become temporarily unresponsive and my typing will no longer show. It'll be like this for anywhere from 1-15 seconds and it makes it all but impossible to get into a flow. Very frustrating!

Any help would be great.



If you're willing to try, check out the latest IDEA 10.5 EAP and the latest nightly build of the Scala plugin. Lots of improvement from the released versions.

EAP - IntelliJ IDEA - Confluence
Scala Plugin for IntelliJ IDEA - Scala - Confluence


Please, verify whether disabling IntelliLang (or autopopup code completion) helps.

If so, the problem should disappear in IDEA 10.5 (moreover, Scala plugin for 10.5 is generally much faster)
- it's mostly an IDEA problem that appeared after an introduction of "autopopup code completion"

You may record a trace of the CPU activity (in EAPs) by pressing the “Capture CPU Snapshot” button on the toolbar, performing the CPU consuming activity and pressing the button again. After that, a snapshot file gets created, which you can then attach to a forum post or YouTrack issue.


The new feature, highlight unused symbols, also has a few performance problems. I've disabled it starting from tomorrows nightly build until we speed it up a bit.


I've changed the unused symbol inspection to run in the background, so it's once again enabled by default.

If anyone hits a problem with (keyboard) typing latency, please post back here. You can disable the checks under Inspections -> Scala -> {Unused Symbol, and Val could by Var}


Disabling IntelliLang does appear to fix the problem. I'm unable to find the "Capture CPU Snapshot" button on my toolbar - I've disabled a few plugins I didn't feel I required, is this part of a plugin or am I somehow overlooking it? I attempted to use jConsole but it would not connect with IDEA.

Thank you for your help, I will try the current IDEA 10.5 and Scala plugin to see if I notice a difference.


The Capture CPU Snapshot button is only available in Early Access Program builds of IDEA.


CTRL-SHIFT-A "Capture CPU Snapshot" will find the Action. If it's missing, it means that IntelliJ was not started with the YourKit profiler agent. The easiest way to get the buttons is to use an EAP build of IDEA, such as 10.5.


I'm now using IntelliJ IDEA CE IC-106.561 with Scala 0.4.911 and I'm still exeperiencing the latency issues while typing, especially while typing within a method call. I've disabled "Unused Symbol" and "var could be a val" inspections but I haven't noticed a difference in the latency problems. I'm still unable to use the CPU Snapshot utility, it doesn't appear when I use the action finder.

Additional information: I'm running Windows 7 64-bit with, I assume, the JRE bundled with IDEA.

Update: It appears that I was too quick to judge, after several hours of work I've noticed a very large difference in the performance. While at times it can still lag, it recovers within a second and isn't very disruptive.


Please sign in to leave a comment.