Regression: Autocompletion overzealous

Hi, I'm noticing a very annoying behaviour since recently, I don't know if this is because something changed about the auto completion, or the plugin just got "too fast":

Case 1

When I open a closure and want to write an argument name, the auto completion jumps in and poses a serious burden on my productivity. This is what happens:

I want to write

    csr.t { w =>  ... }

but as soon as i hit the space bar after the "w", the plugin finds some random symbol around that begins with "w" and completes it. i find myself deleting this wrong completion all the time now, it is extremely annoying. i often get the completion two or three times because i doesn't get in my head that i must press Escape after the w to be even able to insert the space character.

another example is with implicits, e.g.

    TxnExecuter.defaultAtomic { implicit txn => ... }

same thing happens, after i type the "i" of implicit, the plugin (even without me pressing spacebar) is very fast popping up some random completion and i'm lost.

Would it be possible to deactivate the autocompletion after i open a curly brace or parenthesis, or at least keep it quiet until i really want autocompletion, e.g. ctrl+space or something?

Case 2

The same annoying behaviour happens when defining classes. I tend to add the type parameter _after_ i write the constructor. For instance, first I write:

    class Test( w: W )

then I am adding W as a type parameter:

    class Test[ W <: World ]( w: W )

This is due to the structure of my brain, so there is no way I will start with the type parameters, so this procedure is a given fact. So what happens is that after I type the "W" in the first go, the plugin is smart and also inserts some random completion.


Any thoughts how I can get back to the previous, less interfering behaviour?

Thx, -sciss-

4 comments
Comment actions Permalink

correction about the "implicit" example: it waits till i'm finished with the whole word "implicit" and when i press the spacebar then, it believes i want to write "implicitly" which obviously i do not want.

the solution could be that the accept key for completion is changed to return instead of spacebar. hasn't it been this way before, anyway?

0
Comment actions Permalink

Arr well, nevermind. I found the settings for "Preselect the first suggestion" --> "Never" now. Should have checked the prefs first.

best, -sciss-

0
Comment actions Permalink

We shouldn't have to change this - it still counts as a bug in my book.

Though so far, I've only had problems with "if" being turned into
"int2float". However, "if" is sort of important.

Donald

On 4/9/11 8:53 PM, Hanns Holger Rutz wrote:

Arr well, nevermind. I found the settings for "Preselect the first suggestion" -->  "Never" now. Should have checked the prefs first.

>

best, -sciss-

>

---
Original message URL: http://devnet.jetbrains.net/message/5299977#5299977


0
Comment actions Permalink

That's fixed now, check the next nightly.

0

Please sign in to leave a comment.