Always space after a colon

When I implement a method (ctrl - i) that has parameters, the editor puts in a space after the colon. e.g.

def bla(first: Int) ...

I would like it to be:

def bla(first:Int) ...

I used to be able to do this in the Code Style | Spaces section of the settings but I can't find where it is now.

Am I missing something?

Thanks, Nick.

3 comments
Comment actions Permalink

Just added fix for this.
Now you will be able to configure this in settings -> Code Style -> Spacing -> Other.
Thank you for your report.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Thanks for the quick response.

Nick.

0
Comment actions Permalink

Please don't write code like that. It really hurts my eyes to see such misleading formatting.


Randall Schulz

0

Please sign in to leave a comment.