Cannot update to 0.4.472 - "com.intellij.spring: error in opening zip file" for IDEA 10.0.2 CE

Currently, I can't update to the latest plugin version through the Update Manager - it tells me that the Scala plugin has a dependency on the Spring plugin, and then fails to download the Spring plugin with the error above.

Is this because I'm using Community Edition, and the Spring plugin only exists in the full version of IDEA?

If so, is there going to be a release of the Scala plugin that is compatible with the Community Edition, or are they all going to depend on the Ultimate edition from now on?

Cheers

Inigo

2 comments
Comment actions Permalink

That is IDEA's bug, I hope it will be fixed in next releases.
Please watch http://youtrack.jetbrains.net/issue/IDEA-65502, last comment contains workaround for this problem.
Dependenct on Spring plugin is optional. So plugin of course is compatible with IDEA CE.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Great - thank you!

0

Please sign in to leave a comment.