"Scala SDK is not specified" when click debug or run on scala file

How to get rid of this popup, and make idea to run scala file with tests?
It first appeared since i reimport maven project. Accidentally deleted idea project files, so had to make it. Before reimport idea succesfully run specs tests i wrote, after i tweaked maven pom to include scala compiler as dependecy.
Upgrading to 9.02EAP and recent version of scala plugin(0.3.752) did not helped.

9 comments

This could mean that the Scala Facet has not been added to the Module, or that the module classpath does not contain scala-compiler.jar and scala-library.jar.

0

Module does have scala facet, autocomplition works well. Scala compiler and library are listed as maven dependencies.
~/scala/lib/scala-compiler.jar and library are there on their places and specified in module's scala facet  options. SCALA_HOME is set right and scalac is on bin path.
Any other path?

0

Same Problem here!

I have imported an existing eclipse-project and IDEA automatically added the scala-facet.
I could not even build, I had to create a global library pointing to *all* the scala 2.8 RC3 jars.
But running the beast always errors with: Error running X: Scala SDK not specified.

I already switched my global Scala-Library from "compile" to "runtime", but this does not help either.

In the module settings, under facets, my module is correctly listed having the scala facet.
The checkboxes were all unchecked, I tried it with enabling those but this did not have any effect either.

Any idea? Thanks!

0

i discovered accidentally that my problem dissappeared itself some time ago for unknown reason
i'm using 2.77 scala, maven, latest sacala plugin version aviable for latest idea version.

0

Ditto - quite annoying. Comes and goes...

0

I created a global library linking to all scala-stuff and checked the scala-facet properties to manually link to the scala-stuff, this worked...
But it's a P I T A

0

FYI this disappeared for me the other day after my computer crashed, and I rebooted - it was gone.

Today it's back :/

0

We will rework compiler soon. So I hope, that all problems will be fixed.
Also for compilation (and it will be much faster) you can use just released by Esko Luontola sbt plugin http://plugins.intellij.net/plugin/?idea&id=5007

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.