6 comments
Comment actions Permalink

HoD,

That's really too little information to go on. Plus, it doesn't sound like a question about the plug-in, but rather the language itself and perhaps the way you've configured things locally.

Why don't you join us on the #scala Freenode IRC channel? We usually put such questions to rest quite quickly.


Randall Schulz

0
Comment actions Permalink

i suspected the plugin to be the culprit because the code compiles, but when running it, it seems like another version of the class is used (which doesn't have the method)

0
Comment actions Permalink

probably a similar problem, i suddenly get:
Exception in thread "main" java.lang.NoClassDefFoundError: scala/runtime/NonLocalReturnControl

at some line in a constructor looking like this
val x = new y()

it worked fine the last week

0
Comment actions Permalink

could it be that the scala plugin compiles against a random build of scala instead of 2.8-beta? would explain these errors

0
Comment actions Permalink

Scala plugin currently compiles under trunk scala plugin version (when scala plugin was builded).
For using Scala Beta1, you should setup appropriate settings in Scala Facet page for each module.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

fixed it by using the same scala build as the plugin

0

Please sign in to leave a comment.