Is there a way to disable features to solve performance problems ?

I am having having serious performance problems editing
some scala files, since I've moved to the 2.8.0 version. i.e.
up to a few seconds of freeze per key stroke. It would be nice
if I could disable some features like live syntax checking to
see if it solves the problem.

Thanks

18 comments
Comment actions Permalink

There is no way to disable features. All performance problemce should be solved. Current known problem is that icons calculating is really long and works in main thread. So if you want to avoid freezes you can close project view and navigation bar and open only one tab, so it calculates only one icon. I think this will be fixed. But few seconds freezes it's to much, It's possible that you use old plugin version.
Which plugin version you use?

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

I'm also very interested in a better performance of IDEA. It's great that IDEA's code helper is able to recognize the types of complex expressions now. That's definitely don't want to miss this that, but on the other hand IDEA became nearly unusable in the last weeks. I'm currently working with IDEA 92.105 and the Scala plugin 307. When I edit Java, Scala or XML files IDEA constantly hangs for 2 - 5 seconds (at least in one of my projects where I have about 200 Java and 60 Scala classes) after typing at least one character and making a small pause of 500ms. When it hangs IDEA consumes 100% CPU and does not update the editor. That means during the "pause" I have to write blind or wait until IDEA got ready with parsing or what ever it's doing.

Is this a bug or just a performance issue that's going to be solved in the next EAP releases?

PS: I'm also going to test this IDEA version with normal Java project to see if it's related to the Scala plugin and post my results here.
0
Comment actions Permalink

It's related to Scala plugin, because in Scala plugin all calculations are long.
Can you send thread dumb for such hungs? Because performance can be slow on some features invocation or highlighting, but it shouldn't freeze editor. So it's a bug.

Best regards,
Alexander Podkhalyuzin

0
Comment actions Permalink

I too am back to copying code into an external text editor because each character/cut/paste takes seconds. I see this only with the production idea and latest plugin. I was going to go back to the latest eap and previous scala, but the eap downloads are gone and the previous plugin does not load with the production release.

I wish you would consider (if feasable) the ability to selectively diable features. This would allow us to better pinpoint where the problem lies while also allowing to continue working with builds that are otherwise not useful.

-barry

0
Comment actions Permalink

Alexander, you can "experience" the slowdown using the project I attached to http://youtrack.jetbrains.net/issue/SCL-1590 and editing any of  IntervalTimeline.scala, IntervalMap.scala, IntervalTimelineTests.scala

0
Comment actions Permalink

OK. Here is the thread dump (attached).



Attachment(s):
ThreadDump.txt.zip
0
Comment actions Permalink

By the way is it possible to deactivate the code analysis that is performed before every svn commit? At the moment this takes up to 1 minutes per commit and is completely useless for me, since IDEA claims about Scala related errors that do not really exists (SCL-1309).

0
Comment actions Permalink

In addition, those files will contain several editor type errors, yet compile. For example, Tuple2 and Some are not found. I could live with the errors, but I get a constant intention popup to import the missing types -- of course importing does not good. (Hopefully that project is not too much change from my trunk thought)

0
Comment actions Permalink

Here are traces that comming out to the console...



Attachment(s):
scala-spin-dump.txt.zip
0
Comment actions Permalink

Hello Stefan,

Sure. There's a checkbox in the commit dialog for that.

By the way is it possible to deactivate the code analysis that is
performed before every svn commit? At the moment this takes up to 1
minutes per commit and is completely useless for me, since IDEA claims
about Scala related errors that do not really exists
(http://youtrack.jetbrains.net/issue/SCL-1309


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Oh. I havn't seen that yet. Thank you very much!

0
Comment actions Permalink

Seems that it's not performance issue, it's SOE. I'll look at this tomorrow.

0
Comment actions Permalink

You can disable AutoImport feature on file, if you have wrong red code (on which I'll also look tomorrow, because it's seems critical).
Look at small face on the bottom of IDEA UI. Press on this face and turn off checkbox about import popup.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Thank you for the tip with the face on the bottom of IDEA. I did not know that you can disable features there. I disabled the import popup and even the syntax highlighting (set to none). I disabled even all inspection via the "configure inspection"->"reset to empty", but the performance problem remains. I attached another thread dump that I created during the hang. Maybe that helps.



Attachment(s):
ThreadDump.txt.zip
0
Comment actions Permalink

I think you can return highlighting level, because it's not a reason for freezes.
Reason for freezes is toolbar, or Run Configurations checkbox.
As workaround you can switch off toolbar, or change your current run configuration to some neutral (which don't cause freezes).
Switched off toolbar is good idea, because IntlliJ IDEA has following feature: http://blogs.jetbrains.com/idea/2009/10/invoking-rundebug-actions-in-intellij-idea-9/
All of this just workaround. Performance should be improved in some of next plugin releases.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Damn, you're right! Disabling the toolbar solved it. Thanks a lot!

And the F9 key for changing the run configuration is a good alternative to the toolbar. When I recently discovered it I liked it very much.

So, thanks again!

0
Comment actions Permalink

Disabling the toolbar has had little effect for me. I still see 1..2 second delays for keystrokes. Even moving the cursor around can take seconds.

0
Comment actions Permalink

It seems that disabling the toolbar also helped me (see other thread). Thanks for the advice!

0

Please sign in to leave a comment.