no code insight


I just started using the scala plugin.
For some reason I do not get any code insight etc... It seems that it can not find any of the scala libraries.

I did change the scala pluging configuration to point to my local scala 2.8 beta1 libraries.

Does anybody have any tips?

Regards Jaco


Ok, I found the issue. I did not have project level library with the scala libs.


For example, if you write the following code:
    val ten: RichInt = 10
    val range =

Then you will indeed get intellisense/auto completion/code insight help when you press the "." after the "ten" in the second row.

However, for the following code (which compiles and works fine) you will _not_ get any auto completion help:
    val ten: Int = 10
    val range =

and also (not surprisingly, considering that the above neither gave you any auto completion help) the following working code will neither offer any auto completion:
    val range =

So, I think it would be very desirable that the IDE can offer autocompletion for the kind of methods that indeed will work, including methods which will be available through  implicit conversions.

/ Tomas


Which version of Scala plugin are you using? May this is old version, in which you should to hit completion twice to get 'to' completed.

Best regards,
Alexander Podkhalyuzin.


I am using version 0.3.473, which currently (2010-02-12) is listed at the latest version at the page

I can also mention that I am using the Intellij IDEA community edition 9.0.1.

I am not sure what actual keystrokes you are talking about when writing "hit completion twice".

When I press the dot once I get the popup list, and then I have tried to press the combinations of CTRL+SPACE , and CTRL+SPACE+SHIFT , and CTRL+SPACE+ALT.

I have also tried these key combinations twice in a row, but that does not seem to offer any more alternatives in the dropdown list.

/ Tomas


Please sign in to leave a comment.