SBT Refresh Resetting Compile Order

I have a project which requires Compile order in the Scala Compiler to be set to "Java then Scala".  Every time a refresh on the project is called, it creates a new Scala Compiler (SBT 1) and the Compile order gets switched back to "Mixed".

I have tried adding 

compileOrder := CompileOrder.JavaThenScala

to the build.sbt files, but this does not seem to matter.

Is there a way for Intellij to remember my settings for this?

Thanks.

1 comment
Comment actions Permalink

This sounds like a bug in the import process. Thanks for reporting it!

I've created an issue on YouTrack to handle it: https://youtrack.jetbrains.com/issue/SCL-11106

0

Please sign in to leave a comment.