Failure when loading a project

Hi folks,

I am trying to use IDEA 8.1.3 for Scala development, but unfortunately I get ClassCastException during project loading, similar to what is described in SCL-1396. This bug makes the plug-in barely usable, could you please look into it?

  Thanks in advance,
    Yardena.

0
8 comments

I'll look at your problem. But I haven't any idea now where is a problem.

Best regards,
Alexander Podkhalyuzin.

0

I don't get a ClassCastException when I load a project but I have a similar problem. When I start IDEA the first project is never correctly loaded (only if the Scala plugin is enabled). I always have to close the project again and then reopen it. I filed the corresponding bug report here: http://jetbrains.net/tracker/issue/SCL-1532

0

This is fixed now. You can try tomorrow Nightly Build to check it.

Best regards,
Alexander Podkhalyuzin.

0

Yes, it works! Thank you very much!

Regards,
Stefan

0

Is this also fixes compilation for you?

Best regards,
Alexander Podkhalyuzin.

0

Sorry, but issue SCL-1530 remains.

0

OK, now I discovered something interesting. When I rename the IDEA configuration directory (~/.IntelliJIdea90) in order to simulate a fresh installation there is no compiling error anymore. I try to investigate this in more detail to determine if it's another plugin that is responsible for this behavior.

Edit: The bug tracker is up again. -> My next comments will appear in issue SCL-1530.

0

Thank you very much, the error is gone!

0

Please sign in to leave a comment.