Stackoverflow error when browsing java or scala files

Hi people. I've been reporting this error for a while. It happens all the time and is starting to bug me

The latest version of it is reported here (although it has been occuring for the last several updates):

http://www.jetbrains.net/jira/browse/SCL-1001

Please can you have a look at it?

Thanks, Paul.

7 comments
Comment actions Permalink

As I see http://www.jetbrains.net/jira/browse/SCL-1002, your caches are corrupted. I can recommend you to remove folder with caches.
If you use windows, you can found it under C:\Users\User name\.IntelliJIdea8x
After rebuilding caches your exceptions can disappear.

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

HI Alexander, thanks for the response.

I deleted the folder:

~/.IntelliJIdea80/system/caches

(linux) and restarted idea.

I got the stackoverflow as soon as I opened up my project and started to browse java files. Maybe something in my project is corrupting my cache? This will be difficult to track down!

Any ideas?

Thanks, Paul.

0
Comment actions Permalink

Stackoverflow possible is not caused by caches corrupting, by SCL-1002 is really caused.
Did you get stackoverflow for any project and any files?
I meant not only caches folder. I meant all system folder, but may be better to delete just index folder (this contains caches which may cause problems).

Best regards,
Alexander Podkhalyuzin.

0
Comment actions Permalink

Hello, Paul.

Looks like a bug in the type inference algorithm of Scala plugin. In fact it definitely may be reproduces on some particular file (or a little bunch of)/ Could you try to attach suach a file to mentioned issue?
Thanks and sorry for inconvenience.

With best regards,
Ilya Sergey

0
Comment actions Permalink

Hi Ilya.

I managed to reproduce it! I've attached two files to the issue. Whilst investigating this I found the reason for another bug as well so will add an issue for that as well

Please fix!!!!

Thanks, Paul.

0
Comment actions Permalink

Fixed in the last plugin build.

WBR,
Ilya

0
Comment actions Permalink

Thanks Ilya. I can confirm that this has been resolved.

Paul.

0

Please sign in to leave a comment.