Lost "Run..." menu items (in last build?)

Just last night after updating the plugin, I was so happy to see that I could select a file and run the tests. I was also able to select a package and run all test. Then tonight I updated again and all that is gone. But when I look at the download page, I see that the plugin has not been updated since 03/30. Yet Idea indicates that the plugin needs an update. Its like Idea is stuck.

So I delete the plugin zip from system/plugins and reinstalled. Yet Idea still says an update is available. But sadly, I still cannot use select a class and run the tests. (I can create a config and run tests, that's such a pain). What's really confusing is, since its clear that I the plugin was never really updated, why did I see the run menu item come and then go?

One other thing. Are there any notes indicating what's changed from build to build? Nothing is ever shown in the plugin manager.

your happy scala'er

5 comments
Comment actions Permalink

Also all the "popup->New->Scala*" menu items are gone as well.

0
Comment actions Permalink

Well, I had to do a full reinstall of 8.1 EAP and the Scala plugin. But everthing is back to normal again.

0
Comment actions Permalink

I believe I saw that when I relocated my Scala installation and neglected to update IDEA to track it. Might that have been the case for you?

Randall Schulz

0
Comment actions Permalink

No, I made no changes to my environment other than to iniate the update of the scala plugin. But I did that every day for week, since Idea kept saying that an update was available.

0
Comment actions Permalink

If you have any problems with plugin installation you can install or delete it manually from any file manager.
For windows users(in other OS you can find it in the same way): you can go to folder:
..\Documents and Settings\Your User Name\.IntelliJIdea80\config\plugins\Scala\lib
Here you can find scala plugin jar files. If you delete all of them, you delete plugin. When you download plugin from page http://plugins.intellij.net/plugin/?id=1347, you need to copy all jar files from appropriate zip to this folder, then you install last version.
Today I'll upload new version. I hope, that your problems with plugin version will go away (I mean that "no problems with installing plugin from plugin manager").
If you find any problems after it, please write again.

Best regards,
Alexander Podkhalyuzin.

0

Please sign in to leave a comment.