Scala: Compiler dependency information on disk is corrupted.

Hi guys,
I've got Scala 2.7.3 installed an vanilla IDEA 8.1 (#9732). Since a couple of days, I effectively cannot compile any scala projects anymore. The following error occurs and it just goes on in an endless loop. Rebuild /Compile -> Error -> Rebuild..etc...

Information:Compiler dependency information on disk is corrupted. Rebuild required.
Error:Compiler dependency information on disk is corrupted. Rebuild required.

It is a clean install and accidentally I also had to format my harddrive the last couple of days. After reinstallation the error still occurs. Does not occur with Java projects.

Anyone else experiencing this?


Hi Alexander,
hope you are reading this. I still get the exception mentioned above, here's the log:

2009-03-25 19:31:03,640 [ 272875]   INFO - iler.JavaCompilerParsingThread - Compiler dependency information on disk is corrupted. Rebuild required.
com.intellij.compiler.make.CacheCorruptedException: Compiler dependency information on disk is corrupted. Rebuild required.
    at com.intellij.compiler.classParsing.ClassInfo.<init>(
    at com.intellij.compiler.make.Cache.importClassInfo(
    at com.intellij.compiler.make.DependencyCache.reparseClassFile(
    at com.intellij.compiler.impl.javaCompiler.BackendCompilerWrapper$ClassParsingThread.a(
    at com.intellij.compiler.impl.javaCompiler.BackendCompilerWrapper$
    at com.intellij.openapi.application.impl.ApplicationImpl$
    at java.util.concurrent.Executors$
    at java.util.concurrent.FutureTask$Sync.innerRun(
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
    at java.util.concurrent.ThreadPoolExecutor$
    at com.intellij.openapi.application.impl.ApplicationImpl$1$
Caused by: com.intellij.util.cls.ClsFormatException
    at com.intellij.util.cls.ClsUtil.readU1(
    at com.intellij.util.cls.ClsUtil.readU4(
    at com.intellij.compiler.classParsing.ClassFileReader$ConstantPoolIterator.<init>(
    at com.intellij.compiler.classParsing.ClassFileReader.f(
    at com.intellij.compiler.classParsing.ClassFileReader.e(
    at com.intellij.compiler.classParsing.ClassFileReader.getQualifiedName(
    at com.intellij.compiler.classParsing.ClassInfo.<init>(
    ... 12 more


I cannot now give you correct answer, just can to try give you suggestion: to delete idea caches manually.
If you don't know where you can find it, look at .IntelliJIdea8x and .IntlliJIdea80 folders in your user folder (I mean OS User folder). Under this folders you should delete system folders. It contans all cashes, which might be corrupted. I'm not sure that it helps, but I hope it helps:)

Best regards,
Alexander Podkhalyuzin.


Hi Alexander,
unfortunately I already deleted the caches several times. I don't know why this happens, though?



Yes, this is an IDEA core issue, not related to SCala support. Could you tell your -Xmx and -Xms parameter witch which you run IDEA? In some cases it might be helpful to set up them as follows in $IDEA_INSTALL_DIR/bin/idea.exe.vmoptions file:


Hope this helps.

With best regrads,


Hi Ilya,
I tried your parameters but with no luck. I was running the standard Idea properties before.This compile problem however only occurrs with me scala project and does not affect the Java ones.

Any other suggestions?

Thanks for your help!


Ok, for the cleanness of the experiment, first, send me, please, $IDEA_HOME/system/logs/idea.log file. Second, shut down IDEA and remove two folders: $IDEA_HOME/system/{index,caches}. Finally start IDEA again and recompile your project.

Kind regards,


Hi Ilya,
I sent you the idea.log by email. I also deleted caches, and index, as you recommended, restarted Idea, but the problem is still there


Try the last build. Your problem seems to be fixed.



Hi Ilya,
indeed, in the latest build it's fixed! Thanks a lot.

What exactly was the problem?



The problem was in dependency caches building procedure for compiled files. It started immediately after receiving a message "wrote ...class". In your case some classes were postprocessed by scala compiler being already written. This lead to an inconsistent state.

With best regards,


Please sign in to leave a comment.