Accessing IDEA 8.0 Scala Support

Hi,

I'm setting up my new IDEA 8.0 installation. (Scala support is a big reason for me to do this.)

When I installed the Scala plug-in and restarted IDEA, there was an error while starting up and IDEA disabled it.

Thinking that perhaps Scala was core functionality, I looked for it in the File Types and then in the Help documents and found not one mention of it.

So, what is the proper way to enable Scala support?

I'm running IDEA 8.0.1 EAP #9144 on Sun JDK 1.6.0_10-rc2 on x86 Linux.


Randall Schulz

9 comments
Comment actions Permalink

I think the current Scala plugin has build 9100 as upper limit.
It works with the 8.0 (build 9013) release.

So we just have to persuade the Scala plugin maintainers to release a new version :)

0
Comment actions Permalink

I'm not sure, that we want to work with EAP versions. It is more stable thing to work with Diana release version.
We may to change upper limit, but it can fail for other reasons.

0
Comment actions Permalink

EAP status of the host IDEA version certainly did not seem deter the Groovy / Grails plug-in in its early days!


RRS

0
Comment actions Permalink

Neither did it prevent people from whining about the quality when the bugs were caused by the incompatibility issues:) Still as long as we don't claim release status of the plugin and try it ourselves, I don't think it makes a problem.

Eugene.

0
Comment actions Permalink

Well, I was just ribbing you. I, at least, was very pleased and impressed by your team's work on the Groovy / Grails support. I just heard Glen (of the Sven and Glen show) say the IDEA 8.0 Grails support even does auto-completion for dynamic finder methods. That's pretty cool!

But I don't think we really "whined," though, did we? We reported bugs, which you needed to know about anyway.

Anyway, I think it would at least be a good idea to set the Scala plug-in's "until" build number so what I encountered doesn't happen.


Randall Schulz

0
Comment actions Permalink

personally i prefer to run the latest GA version of intellij (which is 9013 right now), so if my vote counts I would say please work and test the scala plugin against the latest GA version.

either way i appreciate your hard work, just my 2c

Edited by: peter kovac on Nov 20, 2008 5:23 AM

Edited by: peter kovac on Nov 20, 2008 5:23 AM

0
Comment actions Permalink

You can use plugin now with current 8.0.1EAP versions. But plugin provided for 8.0 version, and will be supported for this until the official 8.0.1 release.

Good luck.

0
Comment actions Permalink

You can use plugin now with current 8.0.1EAP versions. But plugin provided for 8.0 version, and will be supported for this until official 8.0.1 release.

Good luck.

]]>

0
Comment actions Permalink

Hello, Alexander,

Thanks for that.

However, I'm slightly confused. Could you perhaps restate or clarify the Scala plug-in's version compatibility w.r.t. IDEA 8.0.1 EAP releases?

Thanks.


Randall Schulz

0

Please sign in to leave a comment.