RubyMine EAP 143.90 Does Not Recognize any gem or rails methods/classes in Insight

After upgrading to the newest EAP (as of October 7), 143.90, RubyMine no longer recognizes any methods, classes, etc. from Rails or other gems (see screenshots).

Additionally, It no longer knows what the "Application" is in the File panel. When you click on "Application" (again, in a screenshot), it changes the File view to "Project" from "Rails", rather than opening the ApplicationController as it did in previous versions, which you could also expand the "Application" icon in the File view and see the relevant helper and the like.

I've tried with a few different projects (all the same) and I've switched SDKs as well (2.2.2 to 2.2.3 and back). No luck.

I've upgraded to the new EAP within RM but then downloaded the .dmg and tried a fresh install (wiped all caches, preferences, etc.). Also, no luck.

Wondering if anyone else has seen this with the new EAP?

EDIT: cannot run a server from within RM as well. Tells me that Puma is undefined in the Gemfile. But I can confirm it is not only in the Gemfile, but also in the list of gems installed in the preferences pane.

EDIT II: Attached log file to the original post



Attachment(s):
Screen Shot 2015-10-07 at 9.50.00 AM.png
Screen Shot 2015-10-07 at 9.49.51 AM.png
Screen Shot 2015-10-07 at 9.48.32 AM.png
idea.log.zip
9 comments
Comment actions Permalink

Could you provide log file?

0
Comment actions Permalink

Just attached it to the original post.

0
Comment actions Permalink

I faced the same issue. RM cannot start unicorn, but it present at SDK.

0
Comment actions Permalink

Looks like it's known issue. We are working on it.

0
Comment actions Permalink

Thank you. Is there a place where I can download previous EAP build?

0
Comment actions Permalink

Unfortunatelly, the downoad link from that page points to https://confluence.jetbrains.com/display/RUBYDEV/RubyMine+EAP , where I can see 143.90 only

0

Please sign in to leave a comment.