Cursor disappears and editing doesn't work in editor in RM

Answered

I am running RM on Linux using X2Go on a winXP machine. I have the following issue. When the RM window does not have the focus and I return to that window, the cursor has disappeared and I can not edit the page. The workaround is to open a tab in RM, e.g. Version Control and then close this tab. The cursor than re-appears on the page I am trying to edit.

Has anyone come across this behaviour and if so do they have a solution for this behaviour?

7 comments

Hello, Hans,

 

sorry for such a delay. Does it happen in the last RubyMine EAP (2016.2)?

0

No this issue has long been resolved. The issue has more to do with the X2Go version. I am using a more stable version since then and this problem never occurred again.

0

Thank you for the update, glad to hear it's fine now.

0

i haven the same issue, 

OS version 

jdk version: 

ideaj version:

0

I have this issue on 2018.1 :(

After 2-4 min the cursor appears again and everything is good but happens 2-3 times a day.

0

I have a similar problem. Whenever the IDE loses focus or I open a popup menu (e.g. Alt + Insert) the cursor is missing and I cannot edit any more. I have to click the mouse into the editor, which reactivates the cursor.

I am running on Ubuntu 18 and have i3 as window manager. This bug occurs on all the computers I used, all having different graphics drivers and graphics cards. I would be happy if this issue could be solved.

0

We have a corresponding issue on our tracker so please add your vote there:

https://youtrack.jetbrains.com/issue/IDEA-191854

0

Please sign in to leave a comment.