RubyMine Alt-/ (dynamic abbreviation) shortcut issues

Hello,

I just got a new computer and installed RubyMine on it.

Now, when I'm editing a file and hit Alt-/ I get a division symbol (÷).

On my old machine (I still have it, so I went back and tested), I get Emacs dabbrev-expand style completion: e.g. if this message forum textbox was my editor, I could type "RubyM" and hit Alt-/ and it would autocomplete to RubyMine.

Can someone tell me how to get this behavior on my new machine?

If it matters, both machines run MacOS 10.10.3, but the old one uses Java 6 and the new one uses Java 8 (I followed some JetBrains guide to allow using the new Java version, and it seems to work fine otherwise).

Thank you!

- nc

3 comments
Comment actions Permalink

Hi,

most likely the difference in how jdks handles Alt+<something>, so the only way to restore the old behavior - use jdk 6

Regards, Oleg.

0
Comment actions Permalink

Thank you for the information.

Do you know how I could possibly work around this issue? I wouldn't be averse to remapping the shortcut, but I can't even tell where it is when I look at Preferences -> Keymap.

- nc

0
Comment actions Permalink

Hi,

well, if this was a RubyMine shortcut try to find it on the system it works (Settings|Keymap) there is a way to search an action by shortcut (see the icon next to the search box)
After you will find it you will be able to find it by name on the system where it doesn't work.

Regards, Oleg.

0

Please sign in to leave a comment.