QuickStart does not result in a Rails App. Rails App Generator "Loading generators..." forever?

I am trying to confirm that my new IntelliJ Ultimate + Ruby Plug In can be used for Rails development.  To this end I installed the Ruby Plug-In and am trying to work thorugh the Quick Start at https://www.jetbrains.com/ruby/quickstart/index.html.  At the end of the workflow, the Rails App Generator does not run, so I don't get anything like a Rails app.  Trying to "Tools...Run Rails Generator" brings up a dialog but then we wait forever "Loading generators...".

This whole installation is new so it seems something didn't install correctly?

It is interesting also that "Preferences....Languages and Frameworks..." doesn't show Ruby at all.  Should it?

I'm new to this whole IntelliJ/Ruby thing, so maybe its user error.  But I can't get through the QuickStart and so something is wrong.

Any insights?

9 comments
Comment actions Permalink

You should see "Ruby SDK and Gems" at "Preferences" -> "Languages and Frameworks".

Did you restart IDEA after you had installed "Ruby plugin"?

Is "Ruby plugin" enabled? (To check this go to "Preferences" -> "Plugins")

0
Comment actions Permalink

Yes.  I have restarted IDEA several times after installation of the Ruby Plugin.

I also uninstalled the Ruby Plugin, restarted, installed the Ruby Plugin, restarted, to no avail.


The Ruby Plugin does show itself as being enabled in "Preferences" -> "Plugins".

Bob
0
Comment actions Permalink

Logfile



Attachment(s):
idea.log.zip
0
Comment actions Permalink

File idea.log says that Ruby plugin was loaded sucessfully. Could you check list of plugins again? There must be something like on my screenshot.



Attachment(s):
Screen Shot 2015-04-23 at 10.42.16.png
0
Comment actions Permalink

Attached is a screenshot of my plugins



Attachment(s):
Screen Shot 2015-04-23 at 8.26.50 AM.png
0
Comment actions Permalink

On you screenshot Ruby plugin is ok.

What about "Languages and Frameworks"?

0
Comment actions Permalink

Languages and Frameworks does not show anything Ruby.



Attachment(s):
Screen Shot 2015-04-23 at 10.59.11 AM.png
0
Comment actions Permalink

Module of your project doesn't have Ruby facet. Looks like you didn't select "Ruby on Rails" project type when you created new project.

You could add "Ruby" facet. To do it open Project Structure (File -> "Project Structure") choose the module and press "+" button on the top of the window (see the first screenshot).
Or you could create new Ruby On Rails project. File -> New Project... and choose "Ruby on Rails" type.



Attachment(s):
Screen Shot 2015-04-23 at 21.15.33.png
Screen Shot 2015-04-23 at 21.15.52.png
0

Please sign in to leave a comment.