Error when auto-installing ruby-debug-base ruby 2.2.0. Should it be using debase instead?

After moving my project from ruby-1.9.3-p551 to ruby-2.2.0, I noticed that RubyMine installed debase for me and all is well. I don't have ruby-debug-base installed in this (newly created) gemset. I'm on RM 7.0.1. Another guy here has had the same experience using RM 7.0.2.

At least two of my coworkers have the following issue though. Both are on RM 7.0.3 (one was using 6.x before, and had the same problem, but I had her update, hoping it would fix the issue).

The issue is, RM offers to install ruby-debug-ide when you first try debugging, and then this error happens (taken from the gem_make.out file):

$ cat /Users/XXXXX/.rvm/gems/ruby-2.2.0@ewok/extensions/x86_64-darwin-13/2.2.0/ruby-debug-base-0.10.5.rc10/gem_make.out

/Users/XXXXX/.rvm/rubies/ruby-2.2.0/bin/ruby -r ./siteconf20150203-2945-12yw8qr.rb extconf.rb

Ruby version 2.2.0 is too new

*** extconf.rb failed ***

Could not create Makefile due to some reason, probably lack of necessary

libraries and/or headers.  Check the mkmf.log file for more details.  You may

need configuration options.

Provided configuration options:











I'm confused because it seems to be installing for her a gem (ruby-debug-base) that I don't even have. Is debase a replacement for ruby-debug-base? Is RM supposed to use it with some versions of ruby? It appears that someone actively doesn't want this ruby-debug-base gem to compile in 2.2.0, so I'm not sure what's going on.

More system info: We're all on Mac OS X 10.9.5.

Message was edited by: Daniel Pritchard

Comment actions Permalink


RubyMine is supposed to use debase for ruby > 2.0.0, so if it tries to install ruby-debug-base it believes that
the sdk is 1.8 or 1.9, I'd check language level of the sdk and if it is 1.8 try to remove it from the list and restart RubyMine.
The sdk will be re-added on startup with (I belieave) the correct langage level.

Regards, Oleg.

P.S. btw parhaps it is a good idea to update RubyMine to 7.0.4

Comment actions Permalink

[edited because I realized what you meant after writing the original message]

Hi Oleg,

Thank you so much for your answer. Everyone affected had "bad" (1.8) language levels on their 2.2.0 rubies. We deleted them in there, restarted RM, and they had reappeared with the right language level:
Thanks for being so responsive to your customers!! This is why I'm proud to use your products :)


Comment actions Permalink

You are welcome.

I'm happy that the problem has been fixed.

Regards, Oleg.

Comment actions Permalink

I am having the same issue with Rubymine trying to use ruby-debug-base when it should be using debase. On Rubymine 6.3, I have language level 1.8 with my ruby 2.3.0, although I have correct language level for my ruby 2.0. Removing the ruby and restarting Rubymine didn't solve the problem. How can I resolve this wrong language level issue?

Comment actions Permalink

Jack, I would remove the ruby in RubyMine, and also just uninstall the ruby entirely. (I use rvm so that's rvm uninstall ruby-2.3.0 ) Then open this screen up, make sure it's gone, then reinstall it and restart rubymine again.


Please sign in to leave a comment.