Debug won't stop on breakpoint for RubyMine 7.0.2 for Ruby 1.8.7 on freebsd

In RubyMine 6.3.3 in my environment, debugging works.  But when using RubyMine 7.0.2, it does not stop on breakpoints.  I can run both RM's side-by-side in the same environment on the same code, and it still doesn't work for 7.0.2.

My environment is

FreeBSD 10.1 64-bit

java 1.7.0_71

ruby 1.8.7

ruby-debug-base (0.10.5.rc10)

ruby-debug-ide (0.4.25)

(ruby-debug not installed)


When I turn on verbose debug output on RM 6.3.3, I get:

/usr/local/bin/ruby -e at_exit{sleep(1)};$stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /usr/bravo00/users/miki/gem/gems/ruby-debug-ide-0.4.25/bin/rdebug-ide --debug --disable-int-handler --port 22550 --dispatcher-port 22551 -- /usr/bravo00/users/miki/rmtest/test.rb

Fast Debugger (ruby-debug-ide 0.4.25, ruby-debug-base 0.10.5.rc10) listens on 127.0.0.1:22550

Connected from localhost

33914: Starting control thread

33914: Processing in control: b /usr/bravo00/users/miki/rmtest/test.rb:1

33914: <breakpointAdded no="1" location="/usr/bravo00/users/miki/rmtest/test.rb:1"/>

33914: Processing in control: start

33914: Starting: running program script

33914: <breakpoint file="/usr/bravo00/users/miki/rmtest/test.rb" line="1" threadId="1"/>

33914: Stopping Thread #<Thread:0x801873350> (33914)

33914: Threads equal: true

33914: Processing in control: th l

33914: <threads>

33914: <thread id="1" status="sleep" pid="33914" />

33914: </threads>

33914: Processing in control: th l

33914: <threads>

33914: <thread id="1" status="sleep" pid="33914" />

33914: </threads>

33914: Processing in control: th l

33914: <threads>

33914: <thread id="1" status="sleep" pid="33914" />

33914: </threads>

33914: Processing in context: th in 1

33914: Processing in context:  w

33914: <frames>

33914: <frame no="1" file="/usr/bravo00/users/miki/rmtest/test.rb" line="1" current='true' />

33914: </frames>

33914: Processing in context: th in 1

33914: Processing in context:  frame 1

33914: Selected frame no 0

33914: Processing in context:  v l

33914: <variables>

33914: </variables>

33914: Processing in context: cont

33914: Resumed Thread #<Thread:0x801873350>

Process finished with exit code 0



In 7.0.2, I get:
/usr/local/bin/ruby -e at_exit{sleep(1)};$stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /usr/bravo00/users/miki/gem/gems/ruby-debug-ide-0.4.25/bin/rdebug-ide --debug --disable-int-handler --evaluation-timeout 10 --rubymine-protocol-extensions --port 29972 --dispatcher-port 29973 -- /usr/bravo00/users/miki/rmtest/test.rb
Fast Debugger (ruby-debug-ide 0.4.25, ruby-debug-base 0.10.5.rc10) listens on 127.0.0.1:29972
Connected from localhost
60934: Starting control thread
60934: Processing in control: b /bravo_pool2/bravo00/users/miki/rmtest/test.rb:1
60934: <breakpointAdded no="1" location="/bravo_pool2/bravo00/users/miki/rmtest/test.rb:1"/>
60934: Processing in control: start
60934: Starting: running program script

Process finished with exit code 0



What do I need to do to get debugging working in 7.0.2?
5 comments
Comment actions Permalink

Hi,

I see different paths for the breakpoint, are you using different projects or the file is sylinked somehow?

Regards, Oleg.

0
Comment actions Permalink

Thanks for looking at this.  I'm using the exact same project.  I have /usr/bravo00 linked to /bravo_pool2/bravo00

0
Comment actions Permalink

Hi,

I think this is a bug I've introduced  in 7.0.X :(
Could you please file a ticket for it in our tracker (https://youtrack.jetbrains.com/issues/RUBY) and I will do my best to fix it in 7.0.3

Regards, Oleg.

P.S. in a mean time you can workaround the problem by not using symlinks     

0
Comment actions Permalink

Thank you.  Using non-symlinked dir path works.

Opened
https://youtrack.jetbrains.com/issue/RUBY-16209

0
Comment actions Permalink

Thank you, will do my best to fix it in 7.0.3 timeframe

Regards, Oleg.

0

Please sign in to leave a comment.