RubyMotion option

Hi Guys,

I'm using the IntelliJ plug (        5.4.0.20130410 ) on intelliJ ultimate 12. I want to use the RubyMotion option but can't find it! When I create a new ruby project I only get Rails and SQL support as project configuration options. I have ruby motion installed etc is there a config option I need to set?

13 comments

Hi, can someone comment on whether the plugin for IntelliJ supports RubyMotion development in a way similar to RubyMine? From the comparison page IntelliJ + plugin vs RubyMine (http://devnet.jetbrains.com/docs/DOC-1146) I understand that the plugin can do what RubyMine can do, once updated. But I don't seem to find any hints related to RubyMotion in the plugin (version  5.4.0.20130410).

Regards,

Peter

0

Ruby plugin doesn't support RubyMotion yet :( There is a ticket about this issue - http://youtrack.jetbrains.com/issue/RUBY-13640

Regards, Oleg.

0

Hi Oleg,

Any ETA on when the plugin will get this functionality?

Thanks,
Mark

0

We do not have final plans on this :(  Use the ticket to vote/get up-to-date information

Regards, Oleg.

0

Thanks, voted on the ticket.

I'm a little confused, though, as the discussion on the RubyMine vs. plugin FAQ page linked to above indicates that the plugin contains all of RubyMine 5.4 (save some late bug fixes).

Regards,

Peter

0

Well, though the description in the doc is correct - we do use the same sources for RubyMine and Ruby plugin, some features (like RubyMotion support)
require some changes to enable them in plugin.  In RubyMotion case it includes some (non-trivial) tecnical problems which are specific for plugin which
were not resolved.  I hope we will resolve them for our next major release, but can not promise this :(

Regrads, Oleg.

0

Hi Oleg,

I think it'd be worth pointing it out on the plugin page that RubyMotion is currently unsupported by IntelliJ. Some people will be making purchasing decisions between RubyMine and IntelliJ based on this support and will pick (wrongly at the moment) IntelliJ.

Regards,
Mark

0

The doc has been updated.

Regards, Oleg.

0

Just checking to see if there has been an update to this now that 6.0.0.20130801 is in the plugin repository and the plugin API change has been completed for 130.1486. Thanks!

0

RubyMotion support has not been added to Ruby plugin yet.

Regards, Oleg.

0

Just a friendly ping to see if this may be happening in the (not near) future. Rubymotion 3 with Android is out now. :)

0

We will try to provide code completion and execution support in near future, but I doubt we will be able to support debugging for Andriod :(

Regards, Oleg.

0

Not a problem. Just bringing it up to par with RubyMine would be awesome. :)

0

Please sign in to leave a comment.