Console output gibberish instead of Cyrillic

I'm running RubyMine with Vagrant remote sdk.
If I start "rails s" in vagrant and print some cyrillic stuff I get everything properly. If I start rails from RubyMine on the Console I get "Галена РЎРёРјРѕРІР". I have put -Dconsole.encoding=UTF-8, I also changed the Default encoding to UTF8, but nothing helped.

4 comments

Is the problem specific for remote execution, or it is reproducible for local sdk too.
What is your local sysytem? What locale settings do you have in vagrant?

Regards, Oeg.

0

Hey Oleg,
My local OS is Windows 7, the Vagrant OS is Ubuntu. The locale is the default one - english, I haven't changed it, Regrettably I don't have a local SDK so I cannot tell if it's only a remote issue.

0

I can't reproduce with remote SDK and with Local SDK. Which RubyMine version do you use? Please provide also the exactly steps to reproduce: e.g. which command do you run and all output (copy/paste all output from tool window).

0

I'm using RubyMine 7, this is the command that I use to start the server:

/home/vagrant/.rbenv/versions/2.0.0-p247/bin/ruby -e '$stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift)' /vagrant/bin/rails server -b 127.0.0.1 -p 3000 -e development
=> Booting Thin
=> Rails 4.1.4 application starting in development on http://127.0.0.1:3000
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server

And I'm just using print statements in the controllers to print database fields.

0

Please sign in to leave a comment.