Can't connect to Vagrant using RubyMine

Wondering if any of you who have Vagrant working with RubyMine could help me out.

I simply cannot get RubyMine to connect to my Vagrant instances. I've tried using existing Vagrant boxes, creating new Vagrant boxes, different server types and I get the same issue every time.

I start a new RubyMine project and go to the Preferences -> Ruby SDK and Gems section. I click the + sign and select New Remote. I browse to my Vagrant instance folder (where my Vagrantfile is located).

At that point, I get a message stating the Vagrant instance is not running and asking if I'd like to start it. This happens regardless of whether or not the Vagrant box is running or not. If I click Yes, it tells me it is starting the Vagrant box (and, if the box was not running, this does in fact start it). Then it comes back with the same dialog saying the instance is not started and asking if I want to start it. Clicking yes continues this loop, while clicking No gives me the following error:

"SSH Config Error: The provider for this Vagrant-managed machine is reporting that it is not yet ready for SSH"

I can "vagrant ssh" into the box with no issue, and I can run "vagrant ssh-config" and get back results. I should add that I am using Vagrant's default config, so I haven't changed the ssh key or config at all. Not sure if I need to configure the server in any way before RubyMine can connect.

If someone can let me know if this works out of the box for you or if you have to change any SSH settings on the Vagrant box, I'd be really thankful - just trying to isolate the problem and get this working.

I am using RubyMine 7.0 on OS X 10.9.5


Comment actions Permalink


the vagrant integartion works for me out-of-the-box.
As far as I know vagrant plugin just runs vagrant commands and check's their output to get information it needs so I'd check
output of "vagrant ssh-config" and "vagrant status" (perhaps it is somehow modified in your case).
I'm using Vagrant 1.6.2, VirtualBox 4.3.18, Mac 10.10.1 (but the integrtion worked correctly before Yosemite too)

Regards, Oleg.

Comment actions Permalink

Oleg -

Thanks for the info. Would it be possible for you to share the contents of your Vagrantfile and/or the output from a "vagrant ssh-config"?

My vagrant status and vagrant ssh commands all work as fact, if I set RubyMine to use ssh instead of Vagrant as the remote interpreter connection mode, I can use port 2222 on localhost and it connects!!

Also, if I start the RubyMine connection with the Vagrant instance stopped, RubyMine displays the message asking me if I'd like to start the instance. If I select Yes, the status of the Vagrant instance does change to running, so RubyMine is able to start the instance. However, it never seems to recognize it is running or see that ssh is configured.

It's driving me crazy!!



Comment actions Permalink

Hi Jim,

one of my Vagrantfiles is attached (it has nothing special)
Here is an output of `vagrant ssh-config` for this file
$ vagrant ssh-config
Host default
  User vagrant
  Port 2222
  UserKnownHostsFile /dev/null
  StrictHostKeyChecking no
  PasswordAuthentication no
  IdentityFile /Users/user/.vagrant.d/insecure_private_key
  IdentitiesOnly yes

  LogLevel FATAL

Hope this helps, Oleg.


Please sign in to leave a comment.