.erb <% %> and <=% %> stopped working

I have rubymine 4.5 and just bought 6.0.  I am fairly new to Rails.  Before when editing an .erb file..if i typed in < I would get dropdowns showing <= and <% that i could select for faster insert.

Now I am just getting HTML tags..it stopped working in both.

ctl space does nothing either..

I figure it must be setting but don't know where.

5 comments
Comment actions Permalink

same here. Workaround suggested by Max Gale doesn't work for me.

0
Comment actions Permalink

I am just using shift > command > .   which inserts <%=  %>     then i just remove the = if i don't need it.  Its faster anyway.

On that note, my prompting also starting working again also.  I think it was working before, its just that all of the HTML tags were higher in the list, and the ERB was further down, so make it ridiculous to select them.
Now for some reason they have move back where they should be.

If i can figure out how to set up the HOT keys for <% %> i will be better.  I tried but could not.

0
Comment actions Permalink

OK for those interested....i just figured this out as an option.  (rubymine has SO many things it does right...has anyone tried the model associations diagram yet...simply the best!)

Anyway...there is a thing called LIVE TEMPLATES.  Get their from preferences.

There will be TEMPLATE GROUPS and with them the code templates.  If you do not already have an ERB template then define it..then within there define you code snippets(you will give them an abbreviation)

If u go in there, there is an existing entry for erb like <%  %>...or maybe not( i may have created earlier playing around..

Anyway the concept is this.  You define the CODE to insert, and you give it an abbreviation.

Then when you press Command J...a dialog box comes up...you enter your abbrevation, and the snippet you defined is there to select.

I created TWO abbreviations.

er   and   er=       which are <% %>     &      <%=   %>     respectively.

When i press command J...i then enter er....and i pick my abbreviation....it inserts the code...

So basically it works like the code completion in a sense...a few more key strokes....

check it out.  there are a TON of them already there for Ruby and Rails...and i think are faster and better than code completion now that i have played with them.

For example try this in a controller......Command J....then enter flash and press enter.    you have the flash construct inserted and ready to go

0

Please sign in to leave a comment.