Code Completion interrupting..

RubyMine is a good IDE, but there is one very frustring aspect of it that I cannot get around ... I've tried various configuraiton settings and nothing seems to work.

It's related to code completion interrupting my typing..

I don't always need code completion, it's a nice to have if I can't remember something I don't use but it's not needed for basic things like when adding the operator in a comparison for an if statement ... but when I use RubyMine what I find is that when I start typing the operator - ==, &&, ||, etc. - it will pop up the auto-complete and try to end my if block right there..

I've tried disabling code completion entirely as far as I can tell (everything under Editor -> Code Completion is unchecked) .. but I still see it.

It happens mostly when I type quickly .. so if I do something simple like:

if i == 2

and type that quickly enough, when I press space after the "==" it will bring up something like this:

Screen Shot 2014-11-01 at 9.57.59 PM.png
this one is using a greater than..

the frustrating part is that if I continue typing a space after the comparison operator it will select "end" there as the default and inject it, breaking the flow of what I'm doing.

it's very frustrating...anybody have any suggestions?

3 comments
Comment actions Permalink

Hi,

I can't recreate the situations you've described. Could you provide more details about particular case (given code, caret placement, your actions, result code)? Also it could be useful if you attach your settings (File | Export settings).
The possible reason of such behavior: '==' could be live template that you expand by Space, check it in Settings | Live Templates

0
Comment actions Permalink

Looks like result of work Live Templates. Could you check and disable them here: Settings -> Live Templates?

0
Comment actions Permalink

I'll try disabling live templates tonight and let you know - thanks!

0

Please sign in to leave a comment.