Fill from Vagrant config not working

Hi, all -

I'm using RubyMine 6.3 on OS X Mavericks. I've been trying to get RM working with a remote SDK hosted on a Vagrant VM.

I've tried creating a new project in RM and letting RM init the Vagrant box. I've also tried initializing the box myself and just opening the directory with RM. In both cases, the results are the same:

Going into Project Settings --> Ruby SDK and Gems, using the "Fill from Vagrant config" does not work. It asks me if I want to launch the Vagrant box and I say yes. It waits a bit and comes back with the same prompt. If I hit "No" it gives me an error that the box is not setup for SSH. Meanwhile, I can open a terminal, verify the box is running, and run both vagrant ssh and vagrant ssh-config on the box successfully.

I am able to manually plug in the connection info and it works, so a bit confused why it can't read the ssh-config from the box. I am using Ubuntu/Trusty64. Any ideas?

Thanks!

Jim

1 comment
Comment actions Permalink

Hi Jim, this is definetly a problem. Could you please create an issue at http://youtrack.jetbrains.com/issues/RUBY an attach logs to it (you can find your logs from the menu Help | Show logs...)

0

Please sign in to leave a comment.