"Command Key" Getting Stuck when using Ruby Mind

Werid!

I'm getting a random (but pretty consistent) problem whereby when I'm using RubyMine (and typing quickly - I guess) at some point OSX will jump into a mode where it behaves like the Command Key is stuck.

Suddenly you can't type anything any more, the carrot just jumps around, and clicking on anything behaves like the command key is down (eg. clicking on icons opens that Application window in the Finder).

This only happens when I'm working with RubyMine....and while Random, it seems to be happening more and more with the latest release, BUT it's been happening on previous release for me too.

Is anyone else seeing this behavior.  I have to restart the Mac to reset it.  What to do?
Thanks

Phil


Screen shot 2011-02-24 at 3.35.07 PM.png

18 comments
Comment actions Permalink

Really??!!!


This is not happening to anyone else?  It's happening like 10 times a day for me.  Driving me nuts.  Please JetBrains - any ideas?

0
Comment actions Permalink

Hi Phil,

Please attach idea.log as described at http://devnet.jetbrains.net/docs/DOC-1153

0
Comment actions Permalink

Ah, fantastic - you can take a look!!!  Appreciate it Roman.



Attachment(s):
idea.logs.zip
0
Comment actions Permalink

Great - I'll give that a try now.  Thanks Roman.

Out of interest - the logs I sent were on my 3.0 version.  I upgraded to 3.1, and have experienced the same problem....so now I'll check out 3.1.1.
Did you guys do anything specific to address this keyboard problem - or are you just suggesting get on the latest bits?

Thanks!

0
Comment actions Permalink

This is still happening randomly - on that EAP build.

It seems (although it's random so VERY hard to say) - but feels like this might happen after a paste operation.

I've mapped the Ctrl keys along with the Cmd keys for the cut/copy/paste operations (ie. Ctrl + C, Ctrl + V, Ctrl + X).
I've also mapped Home/End keys to behave like should (start end of line).

Would that be the problems.

Having to restart my machine several times a day is starting to make me fall out of love with RubyMine :(.  Starting to ... I still love it.  But what could this be.  Feels like what Visual Studio would do!

Thanks.

0
Comment actions Permalink

Very very definately related to paste. While it's random - the pattern is that it is always after a paste operation.

I've attached my key-mapping.  Is it related to this.

PLEASE PLEASE PLEASE fix this.  Restarting my machine multiple times a day because of RubyMine is really beginning to suck.

Thanks guys.



Attachment(s):
Mac.Settings 07.jar
0
Comment actions Permalink

I think im having the same issue...

I'm not sure whats triggering it in my case but it manifests itself by (usually) going into a multiple cmd+tab cycle. If i hit escape a couple of it comes back.

Its is happening intermittently but at least 4 or 5 times a day, sometimes as much as every ten minutes, it's becomming very frutrating.

Any help on this would be great.

Thanks

PD

0
Comment actions Permalink

Hi,

could you please describe your environment: OS, jdk, RubyMine versions?
Also could you please more precisely describy the problem you have (if it is possible a short screen cast would be the best)

Oleg.

0
Comment actions Permalink

Hi Oleg,

OS: OS X 10.9.2 (13C1021)

Screen Shot 2014-05-20 at 09.39.15.png

The symptoms are:

- at seemingly random times the keyboard input will slow down as if queuing the keystrokes

- the cmd+tab will stop working unless i double hit tab

- then the cmd+tab bar will appear and tab all the way to the right hand side and then stop with the bar still in place

- if i hit escape normal operation usually resumes

- this can happen once a day or every ten minutes(so a screencast would be difficult to do)

- i havent identified a specific set of actions that cause it

Related:

- I generally use an external keyboard but ive removed all usb connections and still get the issue

- It sometimes feels it happens when the machine is running hot although i imagine that is more an effect of the cause

- Weirdly it happened once on my home machine with the same version of Rubymine at the weekend.

- Nothing in the system logs and no rubymine log entry generated.

I think thats everything...

PD

0
Comment actions Permalink

Do you have any special keyborad setting or perhaps you are using some
keyboard-related programs (such as special keyboard layout switcher)

Regards, Oleg.

0
Comment actions Permalink

Oleg,

I have no weird keyboard settings or keyboard related stuff outside of rubymine and just the standard keymappings inside.

I've included my RM settings file which may be useful.

PD



Attachment(s):
settings.jar.zip
0
Comment actions Permalink

Hi,

do you have System Preferences | Accessibility | Keyboard | Sticky keys set on your Mac?

Regards, Oleg.

0
Comment actions Permalink

Hi Oleg,

No Sticky Keys and no other accesibility features enabled.

thanks

PD

0
Comment actions Permalink

Patrick,

Oleg have asked me try to reproduce your problem(I'm QA Engineer). Could you please answer several questions:
- is the problem reproducible on the laptop or iMac?
- how many application are open at the same time?
- is any dependency of the problem with specific application? E.g. when the problem appears you are trying to switch usually for the terminal, or browser or etc
- do you use multiple windows in the RubyMine?
- Is any project open at this time?
- do you use Full screen mode?

Thank you very much.

0
Comment actions Permalink

Hi Anna/Oleg,

Unfortunately i got so frustrated i completely uninstalled then reinstalled RM and it seems to have fixed the issue.

I'll let you know if it comes up again.

thanks for your help

Patrick

0
Comment actions Permalink

Thanks fo reply! Let us know if the problem is reproduced.

0
Comment actions Permalink

Since i last updated this thread after uninstalling and reinstalling RM i have no issues until today. Unfortunately the problem seems to be happening again.

I'm now convinced its RM causing the issue as uninstalling/reinstalling the app completely fixed the probelm.

Have you got any suggestions on a solution other than uninstalling/reisntalling every few weeks?

thanks

Patrick

0

Please sign in to leave a comment.