Rubymine 6.3 error on startup - Compass: Failed to run compass

I don't really know how to get started to even investigate this issue, but with Rubymine 6.3, I get an error when I open Rubymine:

Compass: Failed to run compass

There is no more information.  I normally have my gems installed into vendor/bundle, and include this folder in my project in Rubymine so that my gems are indexed and searchable, but if i do this now I get an error for every gem when Rubymine starts.  The errors for a gem look like:

"Compass: Failed to run compass on '.../vendor/bundle/ruby/2.0.0/gems/pry-'"  (where ... in the path is actually the full qualified path of the file on my system)

When I exclude vendor/bundle from my project, I still get one error.  There doesn't seem to be any impact after startup, although I haven't looked into if the new compass functionality works or not.  I do have compass-rails included in my project, as well as sass-rails.

My environment is mac OSx 10.9.2, RubyMine 6.3.  I use rbenv, and don't install any gems as system gems besides bundler.  Each project I work on has gems installed to vendor/bundle in the project.  Each project has a .ruby-version to signal the version of ruby - the current project is using ruby 2.0.0-p353.


Hi Andy,

At the moment RubyMine tries to run 'compass imports' against each config.rb that it can find in project in order to get information about compass (and its dependencies) files location. Seems that RubyMine doesn't ignore config.rb from excluded roots. Looks like you can't avoid an error, but compass support should work if you have any valid compass config file (it could be empty file) in project.

I filed an issue about it: Feel free to vote for it.


Same issue here, ever since upgrading to RubyMine 6.3.  Added my vote to the issue.


I have the same issue that started when I upgraded to 6.3.
I'm using Rails 3.2.13 with Ruby1.9.3 under Windows.
In my case, I don't include compass directly, but I use the chosen-rails gem which depends on it.
I haven't yet noticed any runtime issues.


I have the same issue, in which upon loading my project with compass gem installed via Bundler, RubyMine presents a cascade of almost a hundred popup notifications about compass not being able to run. I don't have anything configured to run compass automatically so it must be related to this issue. Please look into this, as it's a real nuisance.


I have the same issue. Looking at idea.log, after starting RubyMine in OSX the very last line after startup reads:

2014-04-24 15:17:38,608 [  11978]   INFO - - Executing [/Users/me/.rvm/gems/ree-1.8.7-2012.02@memberhub/gems/compass-0.10.6/bin/compass imports], working dir =[null]

When I run this command myself:

$ /Users/me/.rvm/gems/ree-1.8.7-2012.02@memberhub/gems/compass-0.10.6/bin/compass imports

I get back:

-I /Users/me/.rvm/gems/ree-1.8.7-2012.02@memberhub/gems/compass-0.10.6/frameworks/blueprint/stylesheets -I /Users/me/.rvm/gems/ree-1.8.7-2012.02@memberhub/gems/compass-0.10.6/frameworks/_blueprint_deprecated_imports/stylesheets -I /Users/me/.rvm/gems/ree-1.8.7-2012.02@memberhub/gems/compass-0.10.6/frameworks/compass/stylesheets -I /Users/me/.rvm/gems/ree-1.8.7-2012.02@memberhub/gems/compass-0.10.6/frameworks/_compass_deprecated_imports/stylesheets -I /Users/me.rvm/gems/ree-1.8.7-2012.02@memberhub/gems/fancy-buttons-1.0.6/lib/stylesheets


Hi Loren,

Thank you for report. The issue definitely will be fixed in the next major release. Also I'll try to backport the fix to the next minor release but I can't give any garantees about success of backporting yet.


Please sign in to leave a comment.