RubyMine debugger throwing SegFault

I'm using version 6.0.3 on OSX Mavericks. This just started happening this week. Any help would be greatly appreciated.

/Users/Pro777/.rbenv/versions/2.0.0-p353/bin/ruby -e at_exit{sleep(1)};$stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/ruby-debug-ide-0.4.22/bin/rdebug-ide --disable-int-handler --port 55896 --dispatcher-port 55897 -- /Users/Pro777/Projects/mmp360site/bin/rails server -b 0.0.0.0 -p 3000 -e development
/Users/Pro777/.gem/ruby/2.0.0/gems/debase-0.0.9/lib/debase_internals.bundle: [BUG] Segmentation fault
ruby 2.0.0p353 (2013-11-22 revision 43784) [x86_64-darwin13.0.0]

-- Crash Report log information --------------------------------------------
   See Crash Report log file under the one of following:
     * ~/Library/Logs/CrashReporter
     * /Library/Logs/CrashReporter
     * ~/Library/Logs/DiagnosticReports
     * /Library/Logs/DiagnosticReports
   the more detail of.

-- Control frame information -----------------------------------------------
c:0012 p:-17577378098302 s:0053 e:000052 TOP    [FINISH]
c:0011 p:---- s:0051 e:000050 CFUNC  :require
c:0010 p:0101 s:0047 e:000046 METHOD /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53
c:0009 p:0042 s:0037 e:000036 TOP    /Users/Pro777/.gem/ruby/2.0.0/gems/debase-0.0.9/lib/debase.rb:4 [FINISH]
c:0008 p:---- s:0035 e:000034 CFUNC  :require
c:0007 p:0101 s:0031 e:000030 METHOD /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53
c:0006 p:0074 s:0021 e:000020 TOP    /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/ruby-debug-ide-0.4.22/lib/ruby-debug-ide.rb:8 [FINISH]
c:0005 p:---- s:0019 e:000018 CFUNC  :require_relative
c:0004 p:0056 s:0015 e:000014 TOP    /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/ruby-debug-ide-0.4.22/bin/rdebug-ide:8 [FINISH]
c:0003 p:---- s:0008 e:000007 CFUNC  :load
c:0002 p:0041 s:0004 E:001408 EVAL   -e:1 [FINISH]
c:0001 p:0000 s:0002 E:0019b8 TOP    [FINISH]

-e:1:in `<main>'
-e:1:in `load'
/Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/ruby-debug-ide-0.4.22/bin/rdebug-ide:8:in `<top (required)>'
/Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/ruby-debug-ide-0.4.22/bin/rdebug-ide:8:in `require_relative'
/Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/ruby-debug-ide-0.4.22/lib/ruby-debug-ide.rb:8:in `<top (required)>'
/Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require'
/Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require'
/Users/Pro777/.gem/ruby/2.0.0/gems/debase-0.0.9/lib/debase.rb:4:in `<top (required)>'
/Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require'
/Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:53:in `require'

-- C level backtrace information -------------------------------------------

-- Other runtime information -----------------------------------------------

* Loaded script: /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/gems/2.0.0/gems/ruby-debug-ide-0.4.22/bin/rdebug-ide

* Loaded features:

    0 enumerator.so
    1 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/x86_64-darwin13.0.0/enc/encdb.bundle
    2 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/x86_64-darwin13.0.0/enc/trans/transdb.bundle
    3 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/x86_64-darwin13.0.0/rbconfig.rb
    4 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/compatibility.rb
    5 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/defaults.rb
    6 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/deprecate.rb
    7 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/errors.rb
    8 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/version.rb
    9 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/requirement.rb
   10 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/platform.rb
   11 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/specification.rb
   12 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/exceptions.rb
   13 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb
   14 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/thread.rb
   15 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/monitor.rb
   16 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb
   17 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/rubygems.rb
   18 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/optparse.rb
   19 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/ostruct.rb
   20 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/prettyprint.rb
   21 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/pp.rb
   22 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/x86_64-darwin13.0.0/stringio.bundle
   23 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/x86_64-darwin13.0.0/socket.bundle
   24 /Users/Pro777/.rbenv/versions/2.0.0-p353/lib/ruby/2.0.0/socket.rb

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html


Process finished with exit code 134

1 comment
Comment actions Permalink

Well, I uninstalled the debase gem on the command line and things mysteriously just started working again.

0

Please sign in to leave a comment.