Coffeescript debugger opens .js instead of .coffee file

Hello,

I followed the steps explained in http://confluence.jetbrains.com/display/RUBYDEV/Debugging+CoffeeScript+Code exactly. I have set a breakpoint in my CoffeeScript file:avascript file.

debugging_jpg.jpg

When I start the coffeescript debugging, the coffeescript stops at the breakpoint I have set, but the debugger does not show the coffescript file, instead it shows the transpiled javascript file:

debugging_jpg-2.jpg

When I try the debug example which can be found at https://github.com/JetBrains/coffee-script-debug-example, the debugger does work as expected showing only the CoffeeScript file. I expect there is a setting which is different but I have not found it. Any ideas how to solve this problem so I can step through the CoffeeScript file instead of figuring out which javascript line belongs to which coffeescript line.

Thanks!

3 comments
Comment actions Permalink

Could you describe scructure of "assets" directory of your project? It it's open source project it would be great if you give link to the repository.

0
Comment actions Permalink

Looks like mappings is not configured (see JavaScript Debug run configuration "Remote URLs of local files"). Could you please provide test project?

0
Comment actions Permalink

I cannot share the project because it is a commercial project. To provide a sample, I stripped all the confidential stuff. When I tried it again, the coffeescript debugging suddenly worked... so somehow there must be an issue in my original project because this one is still not working.

0

Please sign in to leave a comment.