Can't start git -- path is not valid

I recently upgraded to Mac OSX 10.8.1, and found that I needed to reinstall Git.  I did that, and Git works fine in the command line now.  

However, when I run RubyMine, it says "Can't start git, probably the path to the Git executable is not valid. Fix it."  It was giving me error=2.

So I went through a number of steps ( and found that my git executable is in /usr/local/git/bin.  This now gives me error=13, "permission denied".

Even after making sure that everything inside /usr/local/git/bin was chmod'd to 755 (I also tried 777 for good measure.), and that it was marked as executable, it still won't work.

I am not sure what else to try.  My RubyMine is 4.5.3.


Comment actions Permalink

This is likely because your SSH creds are not setup correctly.

this will help:

Comment actions Permalink

For those seeing this in the future (hi future person!) this will also happen if you need to reinstall/upgrade XCode.

As a quick test, just open up a terminal, type "git", and hit enter. 1 of 3 things should happen:

- The error "-bash: git: command not found" shows, indicating git isn't in your $PATH

- The error "Invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun" shows, indicating that you need to reinstall/upgrade XCode (the command for doing so will also show)

- The git help information shows, indicating that your $PATH and XCode are both fine.


Please sign in to leave a comment.