Merge conflict does not work

I have been using Rubymine v.6.0.2. I tried to merge 2 branch. I know there would be a conflict but when I tried to merge the branch. I got this pop up window ( see attachedment) . says "Your local changes to the following files would be overwritten by merge .... etc. but there are no files listed in the center it says "No differences" and there are 3 button Force Merge, Smart Merge and Dont Merge. I tried the two button Force Merge and Smart Merge it just give me an error "Couldn't merge ....". Any Idea how to resove this issue? Thanks in advance!



Attachment(s):
Screenshot from 2014-01-22 08:12:11.png
2 comments
Comment actions Permalink

Hi Chris,

The is a couple of open issues about displaying "would be overwritten" error without listing  files: http://youtrack.jetbrains.com/issue/IDEA-81935, http://youtrack.jetbrains.com/issue/IDEA-87853
(e.g. a file might be somehow ignored by RubyMIne, or it can have "assume-unchanged" bit set in Git)

To solve the issue the simplest way is to go to the command line and merge from there: the files should be listed there, and you will be able to deal with them.

However, both "Force Checkout" (git checkout -f; all local changes preventing merge will be reverted) and "Smart Checkout" (stash-checkout-unstash) should work as well. If they don't, please specify which error exactly do you get.

0
Comment actions Permalink

yes you right I tried to do it in the command line it works. But its a little annoying to go back to command line :)

0

Please sign in to leave a comment.