Is there a way to disable auto substitution for t(:blahblah) in editor?

Hi,

In the RM editor, where I use t(:blahblah) for translations, the editor automatically shows the translation (instead of t(:blahblah))  when the file is opened. Now I agree it is a neat feature but I would like to disable it. Is there any way I can do it.

I also saw that recently it started picking up German translations for showing on the screen. Not sure why.

Thanks,
Manan

2 comments

By default, Rubymine 'folds' the i18n strings.

Change Default I18n string folding

  1. Go to the Preferences > IDE Settings > Editor > Code Folding
  2. Under "Collapse by default", uncheck 'Ruby i18n strings'
  
Note: Rubymine remembers proir folds, so if you have previously opened up files with I18n strings in them then they may still be 'folded'.  To resolve this simply unfold the line of code by:
  • Clicking on the I18n String
  • Place cursor on line and then navigate to Code > Folding > Expand
  • Open file and navigate to Code > Folding > Expand All (both should have keyboard shortcuts)
0

Please sign in to leave a comment.